summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.28.4.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.28.4.bb145
1 files changed, 145 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb b/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb
new file mode 100644
index 0000000000..2e3f0aa682
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb
@@ -0,0 +1,145 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
15 file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \
16 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
17 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
18 file://0001-Enable-THREADS_PREFER_PTHREAD_FLAG.patch \
19 file://cross-compile.patch \
20 file://0001-Fix-build-with-musl.patch \
21 file://include_array.patch \
22 file://0001-clang-11-fix-build-errors-due-to-WWc-11-narrowing.patch \
23 file://0001-MiniBrowser-Fix-reproduciblity.patch \
24 "
25SRC_URI[sha256sum] = "821952e8c9303ed752f1fb1d4283f612c25249d00d705d2b79c2db1bc49c9464"
26
27inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc
28
29ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
30REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
31
32CVE_PRODUCT = "webkitgtk webkitgtk\+"
33
34DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libgcrypt \
35 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
36 pango icu bison-native gawk intltool-native libwebp \
37 atk udev harfbuzz jpeg libpng librsvg libtheora libvorbis \
38 ruby-native libnotify gstreamer1.0-plugins-bad \
39 gettext-native glib-2.0 glib-2.0-native libtasn1 \
40 "
41
42PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)} \
43 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '' ,d)} \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2' ,d)} \
45 enchant \
46 libsecret \
47 "
48
49PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
50PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
51PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
52PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
53PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
54PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
55PACKAGECONFIG[opengl] = "-DENABLE_OPENGL=ON,-DENABLE_OPENGL=OFF,virtual/libgl"
56PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
57PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
58PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
59PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
60
61# webkitgtk is full of /usr/bin/env python, particular for generating docs
62do_configure[postfuncs] += "setup_python_link"
63setup_python_link() {
64 if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
65 ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
66 fi
67}
68
69EXTRA_OECMAKE = " \
70 -DPORT=GTK \
71 -DCMAKE_BUILD_TYPE=Release \
72 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
73 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
74 -DENABLE_MINIBROWSER=ON \
75 -DPYTHON_EXECUTABLE=`which python3` \
76 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
77 "
78
79# Javascript JIT is not supported on ARC
80EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF "
81# By default 25-bit "medium" calls are used on ARC
82# which is not enough for binaries larger than 32 MiB
83CFLAGS_append_arc = " -mlong-calls"
84CXXFLAGS_append_arc = " -mlong-calls"
85
86# Javascript JIT is not supported on powerpc
87EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
88EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
89
90# ARM JIT code does not build on ARMv4/5/6 anymore
91EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
92EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
93EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
94
95EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
96EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
97
98# JIT not supported on MIPS either
99EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
100
101# JIT not supported on X32
102# An attempt was made to upstream JIT support for x32 in
103# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
104# unresolved due to limited X32 adoption.
105EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF "
106
107SECURITY_CFLAGS_remove_aarch64 = "-fpie"
108SECURITY_CFLAGS_append_aarch64 = " -fPIE"
109
110FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
111
112RRECOMMENDS_${PN} += "ca-certificates shared-mime-info"
113
114# http://errors.yoctoproject.org/Errors/Details/20370/
115ARM_INSTRUCTION_SET_armv4 = "arm"
116ARM_INSTRUCTION_SET_armv5 = "arm"
117ARM_INSTRUCTION_SET_armv6 = "arm"
118
119# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
120# https://bugs.webkit.org/show_bug.cgi?id=159880
121# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
122# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
123ARM_INSTRUCTION_SET_armv7a = "thumb"
124ARM_INSTRUCTION_SET_armv7r = "thumb"
125ARM_INSTRUCTION_SET_armv7ve = "thumb"
126
127# introspection inside qemu-arm hangs forever on musl/arm builds
128# therefore disable GI_DATA
129GI_DATA_ENABLED_libc-musl_armv7a = "False"
130GI_DATA_ENABLED_libc-musl_armv7ve = "False"
131
132# Can't be built with ccache
133CCACHE_DISABLE = "1"
134
135PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
136src_package_preprocess () {
137 # Trim build paths from comments in generated sources to ensure reproducibility
138 sed -i -e "s,${WORKDIR},,g" \
139 ${B}/DerivedSources/webkit2gtk/webkit2/*.cpp \
140 ${B}/DerivedSources/ForwardingHeaders/JavaScriptCore/*.h \
141 ${B}/DerivedSources/JavaScriptCore/*.h \
142 ${B}/DerivedSources/JavaScriptCore/yarr/*.h \
143 ${B}/DerivedSources/MiniBrowser/*.c
144}
145