summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.14.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.14.5.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.14.5.bb118
1 files changed, 118 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.14.5.bb b/meta/recipes-sato/webkit/webkitgtk_2.14.5.bb
new file mode 100644
index 0000000000..5fb07da26d
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.14.5.bb
@@ -0,0 +1,118 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
15 file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \
16 file://musl-fixes.patch \
17 file://ppc-musl-fix.patch \
18 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
19 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
20 file://0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch \
21 file://detect_atomics.patch \
22 file://x32_support.patch \
23 "
24
25SRC_URI[md5sum] = "7fe3cb2699e64f969b285823c5ae2516"
26SRC_URI[sha256sum] = "3ca8f1c33a9b43d6c753dcac1c0788656930e06382b10fdf5c2805ea8f96369f"
27
28inherit cmake pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even gtk-doc
29
30# We cannot inherit pythonnative because that would conflict with inheriting python3native
31# (which is done by gobject-introspection). But webkit only needs the path to native Python 2.x binary
32# so we simply set it explicitly here.
33EXTRANATIVEPATH += "python-native"
34
35# depends on libxt
36REQUIRED_DISTRO_FEATURES = "x11"
37
38DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
39 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
40 pango icu bison-native gawk intltool-native libwebp \
41 atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \
42 ruby-native libnotify gstreamer1.0-plugins-bad \
43 python-native \
44 "
45
46PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)} \
47 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'webgl opengl', '' ,d)} \
48 enchant \
49 libsecret \
50 "
51
52PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland"
53PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11"
54PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
55PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant"
56PACKAGECONFIG[gtk2] = "-DENABLE_PLUGIN_PROCESS_GTK2=ON,-DENABLE_PLUGIN_PROCESS_GTK2=OFF,gtk+"
57PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
58PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
59PACKAGECONFIG[opengl] = "-DENABLE_OPENGL=ON,-DENABLE_OPENGL=OFF,virtual/libgl"
60PACKAGECONFIG[libsecret] = "-DENABLE_CREDENTIAL_STORAGE=ON,-DENABLE_CREDENTIAL_STORAGE=OFF,libsecret"
61PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
62
63EXTRA_OECMAKE = " \
64 -DPORT=GTK \
65 -DCMAKE_BUILD_TYPE=Release \
66 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
67 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
68 -DENABLE_MINIBROWSER=ON \
69 "
70
71# Javascript JIT is not supported on powerpc
72EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
73EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
74
75# ARM JIT code does not build on ARMv4/5/6 anymore
76EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
77EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
78EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
79
80# binutils 2.25.1 has a bug on aarch64:
81# https://sourceware.org/bugzilla/show_bug.cgi?id=18430
82EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
83EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
84EXTRA_OECMAKE_append_toolchain-clang = " -DUSE_LD_GOLD=OFF "
85
86# JIT not supported on MIPS either
87EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF "
88
89# JIT not supported on X32
90# An attempt was made to upstream JIT support for x32 in
91# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
92# unresolved due to limited X32 adoption.
93EXTRA_OECMAKE_append_linux-gnux32 = " -DENABLE_JIT=OFF"
94
95SECURITY_CFLAGS_remove_aarch64 = "-fpie"
96SECURITY_CFLAGS_append_aarch64 = " -fPIE"
97
98FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
99
100RRECOMMENDS_${PN} += "ca-certificates"
101
102# http://errors.yoctoproject.org/Errors/Details/20370/
103ARM_INSTRUCTION_SET_armv4 = "arm"
104ARM_INSTRUCTION_SET_armv5 = "arm"
105ARM_INSTRUCTION_SET_armv6 = "arm"
106
107# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
108# https://bugs.webkit.org/show_bug.cgi?id=159880
109# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
110# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
111ARM_INSTRUCTION_SET_armv7a = "thumb"
112ARM_INSTRUCTION_SET_armv7r = "thumb"
113ARM_INSTRUCTION_SET_armv7ve = "thumb"
114
115# WebKit2-4.0: ../../libgpg-error-1.21/src/posix-lock.c:119: get_lock_object: Assertion `!"sizeof lock obj"' failed.
116# qemu: uncaught target signal 6 (Aborted) - core dumped
117EXTRA_OECMAKE_append_mipsarchn32 = " -DENABLE_INTROSPECTION=OFF -DENABLE_GTKDOC=OFF"
118EXTRA_OECMAKE_append_mipsarchn64 = " -DENABLE_INTROSPECTION=OFF -DENABLE_GTKDOC=OFF"