summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.14.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.14.2.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.14.2.bb109
1 files changed, 109 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.14.2.bb b/meta/recipes-sato/webkit/webkitgtk_2.14.2.bb
new file mode 100644
index 0000000000..280765c15e
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.14.2.bb
@@ -0,0 +1,109 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
9 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
10 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
11 "
12
13SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
14 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
15 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
16 file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \
17 file://musl-fixes.patch \
18 file://ppc-musl-fix.patch \
19 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
20 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
21 "
22
23SRC_URI[md5sum] = "2fe3cadbc546d93ca68a13756c2be015"
24SRC_URI[sha256sum] = "2edbcbd5105046aea55af9671c4de8deedb5b0e3567c618034d440a760675556"
25
26inherit cmake pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even gtk-doc
27
28# We cannot inherit pythonnative because that would conflict with inheriting python3native
29# (which is done by gobject-introspection). But webkit only needs the path to native Python 2.x binary
30# so we simply set it explicitly here.
31EXTRANATIVEPATH += "python-native"
32
33# depends on libxt
34REQUIRED_DISTRO_FEATURES = "x11"
35
36DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
37 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
38 pango icu bison-native gawk intltool-native libwebp \
39 atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \
40 ruby-native libnotify gstreamer1.0-plugins-bad \
41 "
42
43PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)} \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'webgl opengl', '' ,d)} \
45 enchant \
46 libsecret \
47 "
48
49PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland"
50PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11"
51PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
52PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant"
53PACKAGECONFIG[gtk2] = "-DENABLE_PLUGIN_PROCESS_GTK2=ON,-DENABLE_PLUGIN_PROCESS_GTK2=OFF,gtk+"
54PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
55PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
56PACKAGECONFIG[opengl] = "-DENABLE_OPENGL=ON,-DENABLE_OPENGL=OFF,virtual/libgl"
57PACKAGECONFIG[libsecret] = "-DENABLE_CREDENTIAL_STORAGE=ON,-DENABLE_CREDENTIAL_STORAGE=OFF,libsecret"
58PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
59
60EXTRA_OECMAKE = " \
61 -DPORT=GTK \
62 -DCMAKE_BUILD_TYPE=Release \
63 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
64 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
65 -DENABLE_MINIBROWSER=ON \
66 "
67
68# Javascript JIT is not supported on powerpc
69EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
70EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
71
72# ARM JIT code does not build on ARMv4/5/6 anymore
73EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
74EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
75EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
76
77# binutils 2.25.1 has a bug on aarch64:
78# https://sourceware.org/bugzilla/show_bug.cgi?id=18430
79EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
80EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
81EXTRA_OECMAKE_append_toolchain-clang = " -DUSE_LD_GOLD=OFF "
82
83# JIT not supported on MIPS either
84EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF "
85
86SECURITY_CFLAGS_remove_aarch64 = "-fpie"
87SECURITY_CFLAGS_append_aarch64 = " -fPIE"
88
89FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
90
91RRECOMMENDS_${PN} += "ca-certificates"
92
93# http://errors.yoctoproject.org/Errors/Details/20370/
94ARM_INSTRUCTION_SET_armv4 = "arm"
95ARM_INSTRUCTION_SET_armv5 = "arm"
96ARM_INSTRUCTION_SET_armv6 = "arm"
97
98# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
99# https://bugs.webkit.org/show_bug.cgi?id=159880
100# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
101# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
102ARM_INSTRUCTION_SET_armv7a = "thumb"
103ARM_INSTRUCTION_SET_armv7r = "thumb"
104ARM_INSTRUCTION_SET_armv7ve = "thumb"
105
106# WebKit2-4.0: ../../libgpg-error-1.21/src/posix-lock.c:119: get_lock_object: Assertion `!"sizeof lock obj"' failed.
107# qemu: uncaught target signal 6 (Aborted) - core dumped
108EXTRA_OECMAKE_append_mipsarchn32 = " -DENABLE_INTROSPECTION=OFF -DENABLE_GTKDOC=OFF"
109EXTRA_OECMAKE_append_mipsarchn64 = " -DENABLE_INTROSPECTION=OFF -DENABLE_GTKDOC=OFF"