summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.12.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.12.5.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.12.5.bb113
1 files changed, 113 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.12.5.bb b/meta/recipes-sato/webkit/webkitgtk_2.12.5.bb
new file mode 100644
index 0000000000..57ac35f372
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.12.5.bb
@@ -0,0 +1,113 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
9 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
10 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
11 "
12
13SRC_URI = "\
14 http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
15 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
16 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
17 file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \
18 file://0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch \
19 file://musl-fixes.patch \
20 file://ppc-musl-fix.patch \
21 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
22 "
23SRC_URI[md5sum] = "7a9ea00ec195488db90fdeb2d174ddaf"
24SRC_URI[sha256sum] = "6b147854b864a5f115fadb97b2b6200b2f696db015216a34e7298d11c88b1c40"
25
26inherit cmake lib_package pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even
27
28# We cannot inherit pythonnative because that would conflict with inheriting python3native
29# (which is done by gobject-introspection). But webkit only needs the path to native Python 2.x binary
30# so we simply set it explicitly here.
31EXTRANATIVEPATH += "python-native"
32
33# depends on libxt
34REQUIRED_DISTRO_FEATURES = "x11"
35
36DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
37 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
38 pango icu bison-native gawk intltool-native libwebp \
39 atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \
40 ruby-native libnotify gstreamer1.0-plugins-bad \
41 "
42
43PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)} \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'webgl', '' ,d)} \
45 enchant \
46 libsecret \
47 "
48
49PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland"
50PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11"
51PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
52PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant"
53PACKAGECONFIG[gtk2] = "-DENABLE_PLUGIN_PROCESS_GTK2=ON,-DENABLE_PLUGIN_PROCESS_GTK2=OFF,gtk+"
54PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
55PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
56PACKAGECONFIG[libsecret] = "-DENABLE_CREDENTIAL_STORAGE=ON,-DENABLE_CREDENTIAL_STORAGE=OFF,libsecret"
57PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
58
59EXTRA_OECMAKE = " \
60 -DPORT=GTK \
61 -DCMAKE_BUILD_TYPE=Release \
62 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
63 -DENABLE_GTKDOC=OFF \
64 -DENABLE_MINIBROWSER=ON \
65 "
66
67# Javascript JIT is not supported on powerpc
68EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
69EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
70
71# ARM JIT code does not build on ARMv4/5/6 anymore
72EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
73EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
74EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
75
76# binutils 2.25.1 has a bug on aarch64:
77# https://sourceware.org/bugzilla/show_bug.cgi?id=18430
78EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
79EXTRA_OECMAKE_append_mips = " -DUSE_LD_GOLD=OFF "
80EXTRA_OECMAKE_append_mips64 = " -DUSE_LD_GOLD=OFF "
81EXTRA_OECMAKE_append_toolchain-clang = " -DUSE_LD_GOLD=OFF "
82
83# JIT not supported on MIPS either
84EXTRA_OECMAKE_append_mips = " -DENABLE_JIT=OFF "
85EXTRA_OECMAKE_append_mips64 = " -DENABLE_JIT=OFF "
86
87SECURITY_CFLAGS_remove_aarch64 = "-fpie"
88SECURITY_CFLAGS_append_aarch64 = " -fPIE"
89
90FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
91
92# http://errors.yoctoproject.org/Errors/Details/20370/
93ARM_INSTRUCTION_SET_armv4 = "arm"
94ARM_INSTRUCTION_SET_armv5 = "arm"
95ARM_INSTRUCTION_SET_armv6 = "arm"
96
97# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
98# https://bugs.webkit.org/show_bug.cgi?id=159880
99# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
100# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
101ARM_INSTRUCTION_SET_armv7a = "thumb"
102ARM_INSTRUCTION_SET_armv7r = "thumb"
103ARM_INSTRUCTION_SET_armv7ve = "thumb"
104
105# Invalid data memory access: 0x00000000
106# ...
107# qemu: uncaught target signal 11 (Segmentation fault) - core dumped
108# Segmentation fault
109EXTRA_OECMAKE_append_powerpc = " -DENABLE_INTROSPECTION=OFF "
110
111# WebKit2-4.0: ../../libgpg-error-1.21/src/posix-lock.c:119: get_lock_object: Assertion `!"sizeof lock obj"' failed.
112# qemu: uncaught target signal 6 (Aborted) - core dumped
113EXTRA_OECMAKE_append_mips64 = " -DENABLE_INTROSPECTION=OFF "