summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.12.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.12.4.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.12.4.bb112
1 files changed, 112 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.12.4.bb b/meta/recipes-sato/webkit/webkitgtk_2.12.4.bb
new file mode 100644
index 0000000000..cb333368e4
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.12.4.bb
@@ -0,0 +1,112 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
9 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
10 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
11 "
12
13SRC_URI = "\
14 http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
15 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
16 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
17 file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \
18 file://0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch \
19 file://musl-fixes.patch \
20 file://ppc-musl-fix.patch \
21 "
22SRC_URI[md5sum] = "0331ac714fd1a0587ffea470ef1afb20"
23SRC_URI[sha256sum] = "424d3177599abbc1eb1a1ad7928dd280a62006e992f2fada2e059375a9609a77"
24
25inherit cmake lib_package pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even
26
27# We cannot inherit pythonnative because that would conflict with inheriting python3native
28# (which is done by gobject-introspection). But webkit only needs the path to native Python 2.x binary
29# so we simply set it explicitly here.
30EXTRANATIVEPATH += "python-native"
31
32# depends on libxt
33REQUIRED_DISTRO_FEATURES = "x11"
34
35DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
36 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
37 pango icu bison-native gawk intltool-native libwebp \
38 atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \
39 ruby-native libnotify gstreamer1.0-plugins-bad \
40 "
41
42PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)} \
43 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'webgl', '' ,d)} \
44 enchant \
45 libsecret \
46 "
47
48PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland"
49PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11"
50PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
51PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant"
52PACKAGECONFIG[gtk2] = "-DENABLE_PLUGIN_PROCESS_GTK2=ON,-DENABLE_PLUGIN_PROCESS_GTK2=OFF,gtk+"
53PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
54PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
55PACKAGECONFIG[libsecret] = "-DENABLE_CREDENTIAL_STORAGE=ON,-DENABLE_CREDENTIAL_STORAGE=OFF,libsecret"
56PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
57
58EXTRA_OECMAKE = " \
59 -DPORT=GTK \
60 -DCMAKE_BUILD_TYPE=Release \
61 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
62 -DENABLE_GTKDOC=OFF \
63 -DENABLE_MINIBROWSER=ON \
64 "
65
66# Javascript JIT is not supported on powerpc
67EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
68EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
69
70# ARM JIT code does not build on ARMv4/5/6 anymore
71EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
72EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
73EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
74
75# binutils 2.25.1 has a bug on aarch64:
76# https://sourceware.org/bugzilla/show_bug.cgi?id=18430
77EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
78EXTRA_OECMAKE_append_mips = " -DUSE_LD_GOLD=OFF "
79EXTRA_OECMAKE_append_mips64 = " -DUSE_LD_GOLD=OFF "
80EXTRA_OECMAKE_append_toolchain-clang = " -DUSE_LD_GOLD=OFF "
81
82# JIT not supported on MIPS either
83EXTRA_OECMAKE_append_mips = " -DENABLE_JIT=OFF "
84EXTRA_OECMAKE_append_mips64 = " -DENABLE_JIT=OFF "
85
86SECURITY_CFLAGS_remove_aarch64 = "-fpie"
87SECURITY_CFLAGS_append_aarch64 = " -fPIE"
88
89FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
90
91# http://errors.yoctoproject.org/Errors/Details/20370/
92ARM_INSTRUCTION_SET_armv4 = "arm"
93ARM_INSTRUCTION_SET_armv5 = "arm"
94ARM_INSTRUCTION_SET_armv6 = "arm"
95
96# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
97# https://bugs.webkit.org/show_bug.cgi?id=159880
98# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
99# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
100ARM_INSTRUCTION_SET_armv7a = "thumb"
101ARM_INSTRUCTION_SET_armv7r = "thumb"
102ARM_INSTRUCTION_SET_armv7ve = "thumb"
103
104# Invalid data memory access: 0x00000000
105# ...
106# qemu: uncaught target signal 11 (Segmentation fault) - core dumped
107# Segmentation fault
108EXTRA_OECMAKE_append_powerpc = " -DENABLE_INTROSPECTION=OFF "
109
110# WebKit2-4.0: ../../libgpg-error-1.21/src/posix-lock.c:119: get_lock_object: Assertion `!"sizeof lock obj"' failed.
111# qemu: uncaught target signal 6 (Aborted) - core dumped
112EXTRA_OECMAKE_append_mips64 = " -DENABLE_INTROSPECTION=OFF "