summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.10.7.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.10.7.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb b/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
new file mode 100644
index 0000000000..8812967603
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
@@ -0,0 +1,78 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
9 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
10 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
11 "
12
13SRC_URI = "\
14 http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
15 file://clang.patch \
16 file://0001-Enable-backtrace-on-linux-when-using-glibc.patch \
17 file://0001-Fix-build-with-non-glibc-libraries-on-linux.patch \
18 "
19SRC_URI[md5sum] = "84832b9d8329413b4f1d87df5f7e8efe"
20SRC_URI[sha256sum] = "990d62c82ed6dede31a6ff0a82d847f16b812842ff3e1093d17113627652864e"
21
22inherit cmake lib_package pkgconfig perlnative pythonnative distro_features_check upstream-version-is-even
23
24# depends on libxt
25REQUIRED_DISTRO_FEATURES = "x11"
26
27DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
28 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
29 pango icu bison-native gnome-common gawk intltool-native libwebp \
30 atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \
31 ruby-native libnotify gstreamer1.0-plugins-bad \
32 "
33
34PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)} \
35 ${@base_contains('DISTRO_FEATURES', 'opengl', 'webgl', '' ,d)} \
36 enchant \
37 gtk2 \
38 libsecret \
39 "
40
41PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland"
42PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11"
43PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
44PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant"
45PACKAGECONFIG[gtk2] = "-DENABLE_PLUGIN_PROCESS_GTK2=ON,-DENABLE_PLUGIN_PROCESS_GTK2=OFF,gtk+"
46PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
47PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
48PACKAGECONFIG[libsecret] = "-DENABLE_CREDENTIAL_STORAGE=ON,-DENABLE_CREDENTIAL_STORAGE=OFF,libsecret"
49PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
50
51EXTRA_OECMAKE = " \
52 -DPORT=GTK \
53 -DCMAKE_BUILD_TYPE=Release \
54 -DENABLE_INTROSPECTION=OFF \
55 -DENABLE_GTKDOC=OFF \
56 -DENABLE_MINIBROWSER=ON \
57 "
58
59# Javascript JIT is not supported on powerpc
60EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
61EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
62
63# ARM JIT code does not build on ARMv5/6 anymore, apparently they test only on v7 onwards
64EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
65EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
66
67# binutils 2.25.1 has a bug on aarch64:
68# https://sourceware.org/bugzilla/show_bug.cgi?id=18430
69EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
70
71# JIT not supported on MIPS either
72EXTRA_OECMAKE_append_mips = " -DENABLE_JIT=OFF "
73EXTRA_OECMAKE_append_mips64 = " -DENABLE_JIT=OFF "
74
75FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
76
77# http://errors.yoctoproject.org/Errors/Details/20370/
78ARM_INSTRUCTION_SET = "arm"