summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.10.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.10.4.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.10.4.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.10.4.bb b/meta/recipes-sato/webkit/webkitgtk_2.10.4.bb
new file mode 100644
index 0000000000..4d5aeb48eb
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.10.4.bb
@@ -0,0 +1,75 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
9 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
10 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
11 "
12
13SRC_URI = "\
14 http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
15 "
16SRC_URI[md5sum] = "fb010031c6f61c3a1a00793b112badb5"
17SRC_URI[sha256sum] = "dbf8260da5cac0c74de2d3cce1fe7c519da3cd816a2c769cb6c6d56addd2f055"
18
19inherit cmake lib_package pkgconfig perlnative pythonnative distro_features_check upstream-version-is-even
20
21# depends on libxt
22REQUIRED_DISTRO_FEATURES = "x11"
23
24DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
25 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
26 pango icu bison-native gnome-common gawk intltool-native libwebp \
27 atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \
28 ruby-native libnotify gstreamer1.0-plugins-bad \
29 "
30
31PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)} \
32 ${@base_contains('DISTRO_FEATURES', 'opengl', 'webgl', '' ,d)} \
33 enchant \
34 gtk2 \
35 libsecret \
36 "
37
38PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland"
39PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11"
40PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
41PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant"
42PACKAGECONFIG[gtk2] = "-DENABLE_PLUGIN_PROCESS_GTK2=ON,-DENABLE_PLUGIN_PROCESS_GTK2=OFF,gtk+"
43PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
44PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
45PACKAGECONFIG[libsecret] = "-DENABLE_CREDENTIAL_STORAGE=ON,-DENABLE_CREDENTIAL_STORAGE=OFF,libsecret"
46PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
47
48EXTRA_OECMAKE = " \
49 -DPORT=GTK \
50 -DCMAKE_BUILD_TYPE=Release \
51 -DENABLE_INTROSPECTION=OFF \
52 -DENABLE_GTKDOC=OFF \
53 -DENABLE_MINIBROWSER=ON \
54 "
55
56# Javascript JIT is not supported on powerpc
57EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
58EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
59
60# ARM JIT code does not build on ARMv5/6 anymore, apparently they test only on v7 onwards
61EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
62EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
63
64# binutils 2.25.1 has a bug on aarch64:
65# https://sourceware.org/bugzilla/show_bug.cgi?id=18430
66EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
67
68# JIT not supported on MIPS either
69EXTRA_OECMAKE_append_mips = " -DENABLE_JIT=OFF "
70EXTRA_OECMAKE_append_mips64 = " -DENABLE_JIT=OFF "
71
72FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
73
74# http://errors.yoctoproject.org/Errors/Details/20370/
75ARM_INSTRUCTION_SET = "arm"