diff options
Diffstat (limited to 'meta/recipes-sato/webkit/webkit-gtk_svn.bb')
-rw-r--r-- | meta/recipes-sato/webkit/webkit-gtk_svn.bb | 107 |
1 files changed, 0 insertions, 107 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_svn.bb b/meta/recipes-sato/webkit/webkit-gtk_svn.bb deleted file mode 100644 index b455759f36..0000000000 --- a/meta/recipes-sato/webkit/webkit-gtk_svn.bb +++ /dev/null | |||
@@ -1,107 +0,0 @@ | |||
1 | DESCRIPTION = "WebKitGTK+ is the port of the portable web rendering engine WebKitK to the GTK+ platform." | ||
2 | HOMEPAGE = "http://www.webkitgtk.org/" | ||
3 | BUGTRACKER = "http://bugs.webkit.org/" | ||
4 | |||
5 | LICENSE = "BSD & LGPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://Source/WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \ | ||
7 | file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \ | ||
8 | file://Source/JavaScriptCore/parser/Parser.h;endline=23;md5=2f3cff0ad0a9c486da5a376928973a90" | ||
9 | |||
10 | # Choice of language backends - icu has issues on Big Endian machines so use pango | ||
11 | ICU_LIB = "icu" | ||
12 | ICU_LIB_powerpc = "pango" | ||
13 | |||
14 | DEPENDS = "zlib enchant gnome-keyring libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \ | ||
15 | gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3 ${ICU_LIB}" | ||
16 | DEPENDS += " ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}" | ||
17 | |||
18 | SRCREV_FORMAT = "source" | ||
19 | |||
20 | SRCREV = "101488" | ||
21 | PV = "1.7.2+svnr${SRCPV}" | ||
22 | PR = "r6" | ||
23 | |||
24 | SRC_URI = "\ | ||
25 | svn://svn.webkit.org/repository/webkit/trunk/;module=Source;protocol=http;name=source \ | ||
26 | svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;protocol=http \ | ||
27 | svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;protocol=http \ | ||
28 | file://Makefile \ | ||
29 | file://Makefile.shared \ | ||
30 | file://autogen.sh \ | ||
31 | file://configure.ac \ | ||
32 | file://GNUmakefile.am \ | ||
33 | file://gtk-doc.make \ | ||
34 | file://nodolt.patch \ | ||
35 | file://function-scope.patch \ | ||
36 | file://webgit-gtk_fix_build_with_automake_1.12.patch \ | ||
37 | " | ||
38 | |||
39 | S = "${WORKDIR}/" | ||
40 | |||
41 | inherit autotools lib_package pkgconfig | ||
42 | |||
43 | EXTRA_OECONF = "\ | ||
44 | --enable-debug=no \ | ||
45 | --enable-svg \ | ||
46 | --enable-icon-database=yes \ | ||
47 | --enable-fullscreen-api \ | ||
48 | --enable-image-resizer \ | ||
49 | --enable-link-prefetch \ | ||
50 | --with-gtk=2.0 \ | ||
51 | ${@base_contains('DISTRO_FEATURES', 'opengl', '--enable-webgl', '--disable-webgl', d)} \ | ||
52 | UNICODE_CFLAGS=-D_REENTRANT \ | ||
53 | " | ||
54 | |||
55 | #default unicode backend icu breaks in cross-compile when target and host are different endian type | ||
56 | EXTRA_OECONF_append_powerpc += "--with-unicode-backend=glib" | ||
57 | |||
58 | CPPFLAGS_append_powerpc += "-I${STAGING_INCDIR}/pango-1.0 \ | ||
59 | -I${STAGING_LIBDIR}/glib-2.0/include \ | ||
60 | -I${STAGING_INCDIR}/glib-2.0" | ||
61 | |||
62 | EXTRA_AUTORECONF = " -I Source/autotools " | ||
63 | |||
64 | |||
65 | #| ./Source/JavaScriptCore/heap/HandleTypes.h: In static member function 'static T* JSC::HandleTypes<T>::getFromSlot(JSC::HandleSlot) [with T = JSC::Structure, JSC::HandleTypes<T>::ExternalType = JSC::Structure*, JSC::HandleSlot = JSC::JSValue*]': | ||
66 | #| ./Source/JavaScriptCore/heap/Handle.h:141:79: instantiated from 'JSC::Handle<T>::ExternalType JSC::Handle<T>::get() const [with T = JSC::Structure, JSC::Handle<T>::ExternalType = JSC::Structure*]' | ||
67 | #| ./Source/JavaScriptCore/runtime/ScopeChain.h:39:75: instantiated from here | ||
68 | #| ./Source/JavaScriptCore/heap/HandleTypes.h:38:130: warning: cast from 'JSC::JSCell*' to 'JSC::HandleTypes<JSC::Structure>::ExternalType {aka JSC::Structure*}' increases required alignment of target type [-Wcast-align] | ||
69 | #| {standard input}: Assembler messages: | ||
70 | #| {standard input}:28873: Error: invalid immediate: 983040 is out of range | ||
71 | #| {standard input}:28873: Error: value of 983040 too large for field of 2 bytes at 15110 | ||
72 | #| /OE/shr-core/tmp/sysroots/x86_64-linux/usr/libexec/armv4t-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.6.2/as: BFD (GNU Binutils) 2.21.1 assertion fail /OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/binutils-cross-2.21.1a-r0/binutils-2.21.1/bfd/elf.c:2819 | ||
73 | #| arm-oe-linux-gnueabi-g++: internal compiler error: Segmentation fault (program as) | ||
74 | #| Please submit a full bug report, | ||
75 | #| with preprocessed source if appropriate. | ||
76 | #| See <http://gcc.gnu.org/bugs.html> for instructions. | ||
77 | #| make[1]: *** [Source/JavaScriptCore/jit/libjavascriptcoregtk_1_0_la-JIT.lo] Error 1 | ||
78 | #| make[1]: Leaving directory `/OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/webkit-gtk-1.5.1+svnr90727-r0' | ||
79 | ARM_INSTRUCTION_SET = "arm" | ||
80 | |||
81 | CONFIGUREOPT_DEPTRACK = "" | ||
82 | |||
83 | do_configure_append() { | ||
84 | # somethings wrong with icu, fix it up manually | ||
85 | for makefile in $(find ${S} -name "GNUmakefile") ; do | ||
86 | sed -i s:-I/usr/include::g $makefile | ||
87 | done | ||
88 | } | ||
89 | |||
90 | do_install_prepend() { | ||
91 | cp ${S}/Programs/.libs/jsc ${S}/Programs/jsc-1 || true | ||
92 | } | ||
93 | |||
94 | do_install_append() { | ||
95 | rmdir ${D}${libexecdir} | ||
96 | } | ||
97 | |||
98 | PACKAGES =+ "${PN}-webinspector ${PN}launcher-dbg ${PN}launcher libjavascriptcore" | ||
99 | FILES_${PN}launcher = "${bindir}/GtkLauncher" | ||
100 | FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher" | ||
101 | FILES_libjavascriptcore = "${libdir}/libjavascriptcoregtk-1.0.so.*" | ||
102 | FILES_${PN}-webinspector = "${datadir}/webkitgtk-*/webinspector/" | ||
103 | FILES_${PN} += "${datadir}/webkitgtk-*/resources/error.html \ | ||
104 | ${datadir}/webkitgtk-*/images \ | ||
105 | ${datadir}/glib-2.0/schemas" | ||
106 | |||
107 | |||