summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkit-gtk_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkit-gtk_svn.bb')
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_svn.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_svn.bb b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
new file mode 100644
index 0000000000..fe31b9c24c
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
@@ -0,0 +1,71 @@
1DESCRIPTION = "WebKitGTK+ is the port of the portable web rendering engine WebKitK to the GTK+ platform."
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \
7 file://WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \
8 file://JavaScriptCore/parser/Parser.h;endline=23;md5=2f3cff0ad0a9c486da5a376928973a90"
9
10DEPENDS = "enchant gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs flex-native gperf-native perl-native sqlite3"
11DEPENDS_darwin8 = "curl icu libxml2 cairo libxslt libidn gnutls gtk+ gstreamer flex-native gperf-native perl-native sqlite3"
12
13SRCREV_FORMAT = "webcore-rwebkit"
14
15PV = "1.3.2+svnr${SRCREV}"
16PR = "r0"
17
18SRC_URI = "\
19 svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
20 svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptGlue;proto=http \
21 svn://svn.webkit.org/repository/webkit/trunk/;module=WebCore;proto=http;name=webcore \
22 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKit;proto=http;name=webkit \
23 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http \
24 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitTools;proto=http \
25 svn://svn.webkit.org/repository/webkit/trunk/;module=autotools;proto=http \
26 file://Makefile \
27 file://Makefile.shared \
28 file://autogen.sh \
29 file://configure.ac \
30 file://GNUmakefile.am \
31 file://gtk-doc.make \
32 "
33
34S = "${WORKDIR}/"
35
36inherit autotools lib_package pkgconfig
37
38EXTRA_OECONF = "\
39 --enable-debug=no \
40 --enable-svg \
41 --enable-icon-database=yes \
42 --disable-fast-malloc \
43 "
44
45EXTRA_AUTORECONF = " -I autotools "
46
47do_compile_prepend() {
48 mkdir -p ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
49 mkdir -p ${S}/Programs/
50 cd ${S}/JavaScriptCore/pcre
51 if test -e dftables.c
52 then
53 ${BUILD_CC} dftables.c -o dftables -I. -I../wtf
54 elif test -e dftables.cpp
55 then
56 ${BUILD_CXX} dftables.cpp -o dftables -I. -I../wtf
57 fi
58 cp dftables ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
59 cp dftables ${S}/Programs/
60 cd ${S}
61}
62
63PACKAGES =+ "${PN}-webinspector ${PN}launcher-dbg ${PN}launcher libjavascriptcore"
64FILES_${PN}launcher = "${bindir}/GtkLauncher"
65FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
66FILES_libjavascriptcore = "${libdir}/libJavaScriptCore.so.*"
67FILES_${PN}-webinspector = "${datadir}/webkit-1.0/webinspector/"
68FILES_${PN} += "${datadir}/webkit-1.0/resources/error.html ${datadir}/webkit-1.0/images"
69
70
71