summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb')
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb116
1 files changed, 0 insertions, 116 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb b/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb
deleted file mode 100644
index b9a9d7a002..0000000000
--- a/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb
+++ /dev/null
@@ -1,116 +0,0 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \
7 file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \
8 file://Source/JavaScriptCore/parser/Parser.h;endline=23;md5=b57c8a2952a8d0e655988fa0ecb2bf7f"
9
10PR = "r1"
11
12# Choice of language backends - icu has issues on Big Endian machines so use pango
13ICU_LIB = "icu"
14ICU_LIB_powerpc = "pango"
15
16DEPENDS = "zlib enchant libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
17 gtk+ flex-native gperf-native perl-native-runtime sqlite3 ${ICU_LIB}"
18DEPENDS += " ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}"
19
20# The libxt requires x11 in DISTRO_FEATURES
21REQUIRED_DISTRO_FEATURES = "x11"
22
23SRC_URI = "\
24 http://www.webkitgtk.org/releases/webkit-${PV}.tar.xz \
25 file://nodolt.patch \
26 file://no-gtkdoc.patch \
27 file://webgit-gtk_fix_build_with_automake_1.12.patch \
28 file://bison-2.6.patch \
29 file://obsolete_automake_macros.patch \
30 file://0001-Enable-mips64-build.patch \
31 file://aarch64.patch \
32 file://webkit-gtk-ANGLE-doesn-t-build-with-bison-3.patch \
33 "
34
35SRC_URI[md5sum] = "dcbf9d5e2e6391f857c29a57528b32a6"
36SRC_URI[sha256sum] = "ada02d636af61aed38f142d3cded662d141ce71264f624c4eb873621a74cc9e7"
37
38# webkit-gtk can NOT be built on MIPS64 with n32 ABI
39COMPATIBLE_HOST_mips64n32 = "null"
40
41inherit autotools lib_package gtk-doc pkgconfig distro_features_check
42
43S = "${WORKDIR}/webkit-${PV}/"
44
45# Disabled by default because it pulls in obsolete gstreamer 0.10
46WEBKIT_AUDIOVIDEO ?= "--disable-video --disable-web-audio"
47
48EXTRA_OECONF = "\
49 --enable-debug=no \
50 --enable-svg \
51 --enable-icon-database=yes \
52 --enable-fullscreen-api \
53 --enable-image-resizer \
54 --enable-link-prefetch \
55 --with-gtk=2.0 \
56 --disable-geolocation \
57 ${WEBKIT_AUDIOVIDEO} \
58 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '--enable-webgl', '--disable-webgl', d)} \
59 UNICODE_CFLAGS=-D_REENTRANT \
60 "
61EXTRA_OECONF_append_armv5 = " --disable-jit"
62EXTRA_OECONF_append_armv6 = " --disable-jit"
63
64#default unicode backend icu breaks in cross-compile when target and host are different endian type
65EXTRA_OECONF_append_powerpc = " --with-unicode-backend=glib"
66
67CPPFLAGS_append_powerpc = " -I${STAGING_INCDIR}/pango-1.0 \
68 -I${STAGING_LIBDIR}/glib-2.0/include \
69 -I${STAGING_INCDIR}/glib-2.0"
70
71# ld can run out of memory linking libwebkitgtk!
72#
73LDFLAGS += "-Wl,--no-keep-memory"
74
75EXTRA_AUTORECONF = " -I Source/autotools "
76
77
78#| ./Source/JavaScriptCore/heap/HandleTypes.h: In static member function 'static T* JSC::HandleTypes<T>::getFromSlot(JSC::HandleSlot) [with T = JSC::Structure, JSC::HandleTypes<T>::ExternalType = JSC::Structure*, JSC::HandleSlot = JSC::JSValue*]':
79#| ./Source/JavaScriptCore/heap/Handle.h:141:79: instantiated from 'JSC::Handle<T>::ExternalType JSC::Handle<T>::get() const [with T = JSC::Structure, JSC::Handle<T>::ExternalType = JSC::Structure*]'
80#| ./Source/JavaScriptCore/runtime/ScopeChain.h:39:75: instantiated from here
81#| ./Source/JavaScriptCore/heap/HandleTypes.h:38:130: warning: cast from 'JSC::JSCell*' to 'JSC::HandleTypes<JSC::Structure>::ExternalType {aka JSC::Structure*}' increases required alignment of target type [-Wcast-align]
82#| {standard input}: Assembler messages:
83#| {standard input}:28873: Error: invalid immediate: 983040 is out of range
84#| {standard input}:28873: Error: value of 983040 too large for field of 2 bytes at 15110
85#| /OE/shr-core/tmp/sysroots/x86_64-linux/usr/libexec/armv4t-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.6.2/as: BFD (GNU Binutils) 2.21.1 assertion fail /OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/binutils-cross-2.21.1a-r0/binutils-2.21.1/bfd/elf.c:2819
86#| arm-oe-linux-gnueabi-g++: internal compiler error: Segmentation fault (program as)
87#| Please submit a full bug report,
88#| with preprocessed source if appropriate.
89#| See <http://gcc.gnu.org/bugs.html> for instructions.
90#| make[1]: *** [Source/JavaScriptCore/jit/libjavascriptcoregtk_1_0_la-JIT.lo] Error 1
91#| make[1]: Leaving directory `/OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/webkit-gtk-1.5.1+svnr90727-r0'
92ARM_INSTRUCTION_SET = "arm"
93
94CONFIGUREOPT_DEPTRACK = ""
95
96do_configure_append() {
97 # somethings wrong with icu, fix it up manually
98 for makefile in $(find ${B} -name "GNUmakefile") ; do
99 sed -i s:-I/usr/include::g $makefile
100 done
101}
102
103do_install_append() {
104 rmdir ${D}${libexecdir}
105}
106
107PACKAGES =+ "${PN}-webinspector ${PN}launcher-dbg ${PN}launcher libjavascriptcore"
108FILES_${PN}launcher = "${bindir}/GtkLauncher"
109FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
110FILES_libjavascriptcore = "${libdir}/libjavascriptcoregtk-1.0.so.*"
111FILES_${PN}-webinspector = "${datadir}/webkitgtk-*/webinspector/"
112FILES_${PN} += "${datadir}/webkitgtk-*/resources/error.html \
113 ${datadir}/webkitgtk-*/images \
114 ${datadir}/glib-2.0/schemas"
115
116