summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkit-gtk_1.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkit-gtk_1.8.2.bb')
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_1.8.2.bb93
1 files changed, 93 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_1.8.2.bb b/meta/recipes-sato/webkit/webkit-gtk_1.8.2.bb
new file mode 100644
index 0000000000..cf4129d41c
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkit-gtk_1.8.2.bb
@@ -0,0 +1,93 @@
1DESCRIPTION = "WebKitGTK+ is the port of the portable web rendering engine WebKitK to the GTK+ platform."
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \
7 file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \
8 file://Source/JavaScriptCore/parser/Parser.h;endline=23;md5=b57c8a2952a8d0e655988fa0ecb2bf7f"
9
10# Choice of language backends - icu has issues on Big Endian machines so use pango
11ICU_LIB = "icu"
12ICU_LIB_powerpc = "pango"
13
14DEPENDS = "zlib enchant gnome-keyring libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
15 gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3 ${ICU_LIB}"
16DEPENDS += " ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}"
17
18SRC_URI = "\
19 http://www.webkitgtk.org/releases/webkit-${PV}.tar.xz \
20 file://nodolt.patch \
21 file://no-gtkdoc.patch \
22 file://webgit-gtk_fix_build_with_automake_1.12.patch \
23 "
24
25SRC_URI[md5sum] = "f7bd0bd4f323039f15e19c82a9a8313c"
26SRC_URI[sha256sum] = "0cd69b7c4bf4af3442a5e6777a1487cabf14db15baeeed96d0865419f69b81e6"
27
28inherit autotools lib_package gtk-doc pkgconfig
29
30S = "${WORKDIR}/webkit-${PV}/"
31
32EXTRA_OECONF = "\
33 --enable-debug=no \
34 --enable-svg \
35 --enable-icon-database=yes \
36 --enable-fullscreen-api \
37 --enable-image-resizer \
38 --enable-link-prefetch \
39 --with-gtk=2.0 \
40 --disable-geolocation \
41 ${@base_contains('DISTRO_FEATURES', 'opengl', '--enable-webgl', '--disable-webgl', d)} \
42 UNICODE_CFLAGS=-D_REENTRANT \
43 "
44
45#default unicode backend icu breaks in cross-compile when target and host are different endian type
46EXTRA_OECONF_append_powerpc = " --with-unicode-backend=glib"
47
48CPPFLAGS_append_powerpc = " -I${STAGING_INCDIR}/pango-1.0 \
49 -I${STAGING_LIBDIR}/glib-2.0/include \
50 -I${STAGING_INCDIR}/glib-2.0"
51
52EXTRA_AUTORECONF = " -I Source/autotools "
53
54
55#| ./Source/JavaScriptCore/heap/HandleTypes.h: In static member function 'static T* JSC::HandleTypes<T>::getFromSlot(JSC::HandleSlot) [with T = JSC::Structure, JSC::HandleTypes<T>::ExternalType = JSC::Structure*, JSC::HandleSlot = JSC::JSValue*]':
56#| ./Source/JavaScriptCore/heap/Handle.h:141:79: instantiated from 'JSC::Handle<T>::ExternalType JSC::Handle<T>::get() const [with T = JSC::Structure, JSC::Handle<T>::ExternalType = JSC::Structure*]'
57#| ./Source/JavaScriptCore/runtime/ScopeChain.h:39:75: instantiated from here
58#| ./Source/JavaScriptCore/heap/HandleTypes.h:38:130: warning: cast from 'JSC::JSCell*' to 'JSC::HandleTypes<JSC::Structure>::ExternalType {aka JSC::Structure*}' increases required alignment of target type [-Wcast-align]
59#| {standard input}: Assembler messages:
60#| {standard input}:28873: Error: invalid immediate: 983040 is out of range
61#| {standard input}:28873: Error: value of 983040 too large for field of 2 bytes at 15110
62#| /OE/shr-core/tmp/sysroots/x86_64-linux/usr/libexec/armv4t-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.6.2/as: BFD (GNU Binutils) 2.21.1 assertion fail /OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/binutils-cross-2.21.1a-r0/binutils-2.21.1/bfd/elf.c:2819
63#| arm-oe-linux-gnueabi-g++: internal compiler error: Segmentation fault (program as)
64#| Please submit a full bug report,
65#| with preprocessed source if appropriate.
66#| See <http://gcc.gnu.org/bugs.html> for instructions.
67#| make[1]: *** [Source/JavaScriptCore/jit/libjavascriptcoregtk_1_0_la-JIT.lo] Error 1
68#| make[1]: Leaving directory `/OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/webkit-gtk-1.5.1+svnr90727-r0'
69ARM_INSTRUCTION_SET = "arm"
70
71CONFIGUREOPT_DEPTRACK = ""
72
73do_configure_append() {
74 # somethings wrong with icu, fix it up manually
75 for makefile in $(find ${S} -name "GNUmakefile") ; do
76 sed -i s:-I/usr/include::g $makefile
77 done
78}
79
80do_install_append() {
81 rmdir ${D}${libexecdir}
82}
83
84PACKAGES =+ "${PN}-webinspector ${PN}launcher-dbg ${PN}launcher libjavascriptcore"
85FILES_${PN}launcher = "${bindir}/GtkLauncher"
86FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
87FILES_libjavascriptcore = "${libdir}/libjavascriptcoregtk-1.0.so.*"
88FILES_${PN}-webinspector = "${datadir}/webkitgtk-*/webinspector/"
89FILES_${PN} += "${datadir}/webkitgtk-*/resources/error.html \
90 ${datadir}/webkitgtk-*/images \
91 ${datadir}/glib-2.0/schemas"
92
93