summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/files/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/files/configure.ac')
-rw-r--r--meta/recipes-sato/webkit/files/configure.ac164
1 files changed, 112 insertions, 52 deletions
diff --git a/meta/recipes-sato/webkit/files/configure.ac b/meta/recipes-sato/webkit/files/configure.ac
index d4f3e749fc..bb703b4bf7 100644
--- a/meta/recipes-sato/webkit/files/configure.ac
+++ b/meta/recipes-sato/webkit/files/configure.ac
@@ -2,14 +2,14 @@ AC_PREREQ(2.59)
2 2
3m4_define([webkit_major_version], [1]) 3m4_define([webkit_major_version], [1])
4m4_define([webkit_minor_version], [3]) 4m4_define([webkit_minor_version], [3])
5m4_define([webkit_micro_version], [2]) 5m4_define([webkit_micro_version], [7])
6 6
7# This is the version we'll be using as part of our User-Agent string 7# This is the version we'll be using as part of our User-Agent string
8# e.g., AppleWebKit/$(webkit_user_agent_version) ... 8# e.g., AppleWebKit/$(webkit_user_agent_version) ...
9# 9#
10# Sourced from WebCore/Configurations/Version.xcconfig 10# Sourced from WebCore/Configurations/Version.xcconfig
11m4_define([webkit_user_agent_major_version], [531]) 11m4_define([webkit_user_agent_major_version], [534])
12m4_define([webkit_user_agent_minor_version], [2]) 12m4_define([webkit_user_agent_minor_version], [7])
13 13
14AC_INIT([WebKit],[webkit_major_version.webkit_minor_version.webkit_micro_version],[http://bugs.webkit.org/]) 14AC_INIT([WebKit],[webkit_major_version.webkit_minor_version.webkit_micro_version],[http://bugs.webkit.org/])
15 15
@@ -34,8 +34,8 @@ AC_SUBST(WEBKIT_USER_AGENT_MINOR_VERSION)
34AC_CONFIG_SRCDIR([WebCore/config.h]) 34AC_CONFIG_SRCDIR([WebCore/config.h])
35 35
36dnl # Libtool library version, not to confuse with API version 36dnl # Libtool library version, not to confuse with API version
37dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html#Libtool-versioning 37dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html
38LIBWEBKITGTK_VERSION=0:0:0 38LIBWEBKITGTK_VERSION=4:0:4
39AC_SUBST([LIBWEBKITGTK_VERSION]) 39AC_SUBST([LIBWEBKITGTK_VERSION])
40 40
41AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar]) 41AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
@@ -82,6 +82,8 @@ WEBKIT_INIT
82AC_DISABLE_STATIC 82AC_DISABLE_STATIC
83AC_LIBTOOL_WIN32_DLL 83AC_LIBTOOL_WIN32_DLL
84AC_PROG_LIBTOOL 84AC_PROG_LIBTOOL
85# use dolt to speedup the build
86DOLT
85 87
86AC_PATH_PROG(FLEX, flex) 88AC_PATH_PROG(FLEX, flex)
87if test -z "$FLEX"; then 89if test -z "$FLEX"; then
@@ -165,6 +167,17 @@ if test "$png_ok" != yes; then
165fi 167fi
166AC_SUBST([PNG_LIBS]) 168AC_SUBST([PNG_LIBS])
167 169
170
171if test "$os_win32" = "yes"; then
172 WINMM_LIBS=-lwinmm
173 SHLWAPI_LIBS=-lshlwapi
174 OLE32_LIBS=-lole32
175fi
176AC_SUBST([WINMM_LIBS])
177AC_SUBST([SHLWAPI_LIBS])
178AC_SUBST([OLE32_LIBS])
179
180
168# determine the GTK+ version to use 181# determine the GTK+ version to use
169AC_MSG_CHECKING([the GTK+ version to use]) 182AC_MSG_CHECKING([the GTK+ version to use])
170AC_ARG_WITH([gtk], 183AC_ARG_WITH([gtk],
@@ -186,7 +199,7 @@ case "$with_gtk" in
186 GAIL_PC_NAME=gail 199 GAIL_PC_NAME=gail
187 GAIL_REQUIRED_VERSION=1.8 200 GAIL_REQUIRED_VERSION=1.8
188 ;; 201 ;;
189 3.0) GTK_REQUIRED_VERSION=2.90 202 3.0) GTK_REQUIRED_VERSION=2.91
190 GTK_API_VERSION=3.0 203 GTK_API_VERSION=3.0
191 WEBKITGTK_API_MAJOR_VERSION=3 204 WEBKITGTK_API_MAJOR_VERSION=3
192 WEBKITGTK_API_MINOR_VERSION=0 205 WEBKITGTK_API_MINOR_VERSION=0
@@ -258,7 +271,17 @@ ENCHANT_REQUIRED_VERSION=0.22
258# todo: webcore gtk 271# todo: webcore gtk
259WEBKIT_CHECK_DEPENDENCIES([glib unicode]) 272WEBKIT_CHECK_DEPENDENCIES([glib unicode])
260 273
261GETTEXT_PACKAGE=$PACKAGE 274# Check if we can use GSettings
275PKG_CHECK_MODULES([GSETTINGS],
276 [gio-2.0 >= 2.25.0],
277 [have_gsettings=yes],
278 [have_gsettings=no])
279if test "$have_gsettings" = "yes"; then
280 AC_DEFINE([HAVE_GSETTINGS], 1, [Whether we can use GSettings])
281 GLIB_GSETTINGS
282fi
283
284GETTEXT_PACKAGE=$PACKAGE-$GTK_API_VERSION
262AC_SUBST(GETTEXT_PACKAGE) 285AC_SUBST(GETTEXT_PACKAGE)
263AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", 286AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",
264 [The gettext catalog name]) 287 [The gettext catalog name])
@@ -430,14 +453,6 @@ AC_ARG_ENABLE(datalist,
430 [],[enable_datalist="yes"]) 453 [],[enable_datalist="yes"])
431AC_MSG_RESULT([$enable_datalist]) 454AC_MSG_RESULT([$enable_datalist])
432 455
433# check whether to enable HTML5 ruby support
434AC_MSG_CHECKING([whether to enable HTML5 ruby support])
435AC_ARG_ENABLE(ruby,
436 AC_HELP_STRING([--enable-ruby],
437 [enable HTML5 ruby support [default=yes]]),
438 [],[enable_ruby="yes"])
439AC_MSG_RESULT([$enable_ruby])
440
441# check whether to enable HTML5 sandbox iframe support 456# check whether to enable HTML5 sandbox iframe support
442AC_MSG_CHECKING([whether to enable HTML5 sandboxed iframe support]) 457AC_MSG_CHECKING([whether to enable HTML5 sandboxed iframe support])
443AC_ARG_ENABLE(sandbox, 458AC_ARG_ENABLE(sandbox,
@@ -526,6 +541,22 @@ AC_ARG_ENABLE(workers,
526 [],[enable_workers="yes"]) 541 [],[enable_workers="yes"])
527AC_MSG_RESULT([$enable_workers]) 542AC_MSG_RESULT([$enable_workers])
528 543
544# check whether to enable directory upload support
545AC_MSG_CHECKING([whether to enable directory upload support])
546AC_ARG_ENABLE(directory_upload,
547 AC_HELP_STRING([--enable-directory-upload],
548 [enable support for directory upload [default=no]]),
549 [], [enable_directory_upload="no"])
550AC_MSG_RESULT([$enable_directory_upload])
551
552# check whether to enable HTML5 FileSystem API support
553AC_MSG_CHECKING([whether to enable HTML5 FileSystem API support])
554AC_ARG_ENABLE(file_system,
555 AC_HELP_STRING([--enable-file-system],
556 [enable support for HTML5 FileSystem API [default=no]]),
557 [], [enable_file_system="no"])
558AC_MSG_RESULT([$enable_file_system])
559
529# turn off svg features if --disable-svg is requested 560# turn off svg features if --disable-svg is requested
530if test "$enable_svg" = "no"; then 561if test "$enable_svg" = "no"; then
531 enable_svg_animation=no 562 enable_svg_animation=no
@@ -600,8 +631,8 @@ fi
600AC_MSG_CHECKING([whether to enable Web Sockets support]) 631AC_MSG_CHECKING([whether to enable Web Sockets support])
601AC_ARG_ENABLE(web_sockets, 632AC_ARG_ENABLE(web_sockets,
602 AC_HELP_STRING([--enable-web-sockets], 633 AC_HELP_STRING([--enable-web-sockets],
603 [enable support for Web Sockets [default=no]]), 634 [enable support for Web Sockets [default=yes]]),
604 [],[enable_web_sockets="no"]) 635 [],[enable_web_sockets="yes"])
605AC_MSG_RESULT([$enable_web_sockets]) 636AC_MSG_RESULT([$enable_web_sockets])
606 637
607# check whether to enable Web Timing support 638# check whether to enable Web Timing support
@@ -612,13 +643,13 @@ AC_ARG_ENABLE(web_timing,
612 [],[enable_web_timing="no"]) 643 [],[enable_web_timing="no"])
613AC_MSG_RESULT([$enable_web_timing]) 644AC_MSG_RESULT([$enable_web_timing])
614 645
615# check whether to enable Blob.slice support 646# check whether to enable Blob support
616AC_MSG_CHECKING([whether to enable Blob.slice support]) 647AC_MSG_CHECKING([whether to enable Blob support])
617AC_ARG_ENABLE(blob_slice, 648AC_ARG_ENABLE(blob,
618 AC_HELP_STRING([--enable-blob-slice], 649 AC_HELP_STRING([--enable-blob],
619 [enable support for Blob.slice [default=no]]), 650 [enable support for Blob [default=no]]),
620 [],[enable_blob_slice="no"]) 651 [],[enable_blob="no"])
621AC_MSG_RESULT([$enable_blob_slice]) 652AC_MSG_RESULT([$enable_blob])
622 653
623# check whether to enable Fast Mobile Scrolling support 654# check whether to enable Fast Mobile Scrolling support
624AC_MSG_CHECKING([whether to enable Fast Mobile Scrolling]) 655AC_MSG_CHECKING([whether to enable Fast Mobile Scrolling])
@@ -628,22 +659,6 @@ AC_ARG_ENABLE(fast_mobile_scrolling,
628 [],[enable_fast_mobile_scrolling="no"]) 659 [],[enable_fast_mobile_scrolling="no"])
629AC_MSG_RESULT([$enable_fast_mobile_scrolling]) 660AC_MSG_RESULT([$enable_fast_mobile_scrolling])
630 661
631# check whether to enable FileReader support
632AC_MSG_CHECKING([whether to enable FileReader support])
633AC_ARG_ENABLE(file_reader,
634 AC_HELP_STRING([--enable-file-reader],
635 [enable support for FileReader [default=no]]),
636 [],[enable_file_reader="no"])
637AC_MSG_RESULT([$enable_file_reader])
638
639# check whether to enable FileWriter support
640AC_MSG_CHECKING([whether to enable FileWriter support])
641AC_ARG_ENABLE(file_writer,
642 AC_HELP_STRING([--enable-file-writer],
643 [enable support for FileWriter [default=no]]),
644 [],[enable_file_writer="no"])
645AC_MSG_RESULT([$enable_file_writer])
646
647# check whether to enable code coverage 662# check whether to enable code coverage
648AC_MSG_CHECKING([whether to enable code coverage support]) 663AC_MSG_CHECKING([whether to enable code coverage support])
649AC_ARG_ENABLE(coverage, 664AC_ARG_ENABLE(coverage,
@@ -667,6 +682,11 @@ AC_ARG_ENABLE([jit],
667 [],[enable_jit="yes"]) 682 [],[enable_jit="yes"])
668if test "$enable_jit" = "yes"; then 683if test "$enable_jit" = "yes"; then
669 case "$host_cpu" in 684 case "$host_cpu" in
685 arm*)
686 AC_DEFINE([ENABLE_JIT], [1], [Define to enable JIT])
687 AC_DEFINE([ENABLE_YARR], [1], [Define to enable YARR])
688 AC_DEFINE([ENABLE_YARR_JIT], [1], [Define to enable YARR JIT])
689 ;;
670 i*86|x86_64) 690 i*86|x86_64)
671 AC_DEFINE([ENABLE_JIT], [1], [Define to enable JIT]) 691 AC_DEFINE([ENABLE_JIT], [1], [Define to enable JIT])
672 AC_DEFINE([ENABLE_YARR], [1], [Define to enable YARR]) 692 AC_DEFINE([ENABLE_YARR], [1], [Define to enable YARR])
@@ -688,9 +708,36 @@ if test "$enable_jit" = "yes"; then
688 enable_jit="no (CPU '$host_cpu' not supported)" 708 enable_jit="no (CPU '$host_cpu' not supported)"
689 ;; 709 ;;
690 esac 710 esac
711else
712 AC_DEFINE([ENABLE_JIT], [0], [Define to enable JIT])
691fi 713fi
692AC_MSG_RESULT([$enable_jit]) 714AC_MSG_RESULT([$enable_jit])
693 715
716# Opcode stats
717AC_MSG_CHECKING([whether to enable opcode stats])
718AC_ARG_ENABLE([opcode-stats],
719 [AS_HELP_STRING([--enable-opcode-stats], [Enable Opcode statistics (default: disabled)])],
720 [], [enable_opcode_stats=no])
721AC_MSG_RESULT([$enable_opcode_stats])
722
723if test "$enable_opcode_stats" = "yes"; then
724 if test "$enable_jit" = "yes"; then
725 AC_MSG_ERROR([JIT must be disabled for Opcode stats to work.])
726 fi
727 AC_DEFINE([ENABLE_OPCODE_STATS], [1], [Define to enable Opcode statistics])
728fi
729
730# Link prefetch
731AC_MSG_CHECKING([whether to enable link prefetch support])
732AC_ARG_ENABLE([link-prefetch],
733 [AS_HELP_STRING([--enable-link-prefetch], [Enable Link prefetch support (default: disabled)])],
734 [],[enable_link_prefetch=no])
735AC_MSG_RESULT([$enable_link_prefetch])
736
737if test "$enable_link_prefetch" = "yes"; then
738 AC_DEFINE([ENABLE_LINK_PREFETCH], [1], [Define to enable link prefetch support])
739fi
740
694# GObject Introspection 741# GObject Introspection
695AC_MSG_CHECKING([whether to enable GObject introspection support]) 742AC_MSG_CHECKING([whether to enable GObject introspection support])
696AC_ARG_ENABLE([introspection], 743AC_ARG_ENABLE([introspection],
@@ -705,7 +752,7 @@ GIRDIR=
705GIRTYPELIBDIR= 752GIRTYPELIBDIR=
706 753
707if test "$enable_introspection" = "yes"; then 754if test "$enable_introspection" = "yes"; then
708 GOBJECT_INTROSPECTION_REQUIRED=0.6.15 755 GOBJECT_INTROSPECTION_REQUIRED=0.9.5
709 PKG_CHECK_MODULES([INTROSPECTION],[gobject-introspection-1.0 >= $GOBJECT_INTROSPECTION_REQUIRED]) 756 PKG_CHECK_MODULES([INTROSPECTION],[gobject-introspection-1.0 >= $GOBJECT_INTROSPECTION_REQUIRED])
710 757
711 G_IR_SCANNER="$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)" 758 G_IR_SCANNER="$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)"
@@ -816,9 +863,13 @@ if test "$enable_video" = "yes"; then
816 [gstreamer-0.10 >= $GSTREAMER_REQUIRED_VERSION 863 [gstreamer-0.10 >= $GSTREAMER_REQUIRED_VERSION
817 gstreamer-app-0.10 864 gstreamer-app-0.10
818 gstreamer-base-0.10 865 gstreamer-base-0.10
866 gstreamer-interfaces-0.10
819 gstreamer-pbutils-0.10 867 gstreamer-pbutils-0.10
820 gstreamer-plugins-base-0.10 >= $GSTREAMER_PLUGINS_BASE_REQUIRED_VERSION 868 gstreamer-plugins-base-0.10 >= $GSTREAMER_PLUGINS_BASE_REQUIRED_VERSION
821 gstreamer-video-0.10]) 869 gstreamer-video-0.10],
870 [have_gstreamer=yes],
871 [have_gstreamer=no])
872
822 AC_SUBST([GSTREAMER_CFLAGS]) 873 AC_SUBST([GSTREAMER_CFLAGS])
823 AC_SUBST([GSTREAMER_LIBS]) 874 AC_SUBST([GSTREAMER_LIBS])
824fi 875fi
@@ -859,18 +910,26 @@ AM_CONDITIONAL([USE_GLIB_UNICODE], [test "$with_unicode_backend" = "glib"])
859AM_CONDITIONAL([USE_FREETYPE], [test "$with_font_backend" = "freetype"]) 910AM_CONDITIONAL([USE_FREETYPE], [test "$with_font_backend" = "freetype"])
860AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"]) 911AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
861 912
913# GLib/GIO feature conditionals
914AM_CONDITIONAL([USE_GSETTINGS], [test "$have_gsettings" = "yes"])
915
916# GStreamer feature conditional
917AM_CONDITIONAL([USE_GSTREAMER], [test "$have_gstreamer" = "yes"])
918
862# WebKit feature conditionals 919# WebKit feature conditionals
863AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"]) 920AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
864AM_CONDITIONAL([ENABLE_3D_TRANSFORMS],[test "$enable_3D_transforms" = "yes"]) 921AM_CONDITIONAL([ENABLE_3D_TRANSFORMS],[test "$enable_3D_transforms" = "yes"])
865AM_CONDITIONAL([ENABLE_BLOB_SLICE],[test "$enable_blob_slice" = "yes"]) 922AM_CONDITIONAL([ENABLE_BLOB],[test "$enable_blob" = "yes"])
866AM_CONDITIONAL([ENABLE_CHANNEL_MESSAGING],[test "$enable_channel_messaging" = "yes"]) 923AM_CONDITIONAL([ENABLE_CHANNEL_MESSAGING],[test "$enable_channel_messaging" = "yes"])
867AM_CONDITIONAL([ENABLE_JAVASCRIPT_DEBUGGER],[test "$enable_javascript_debugger" = "yes"]) 924AM_CONDITIONAL([ENABLE_JAVASCRIPT_DEBUGGER],[test "$enable_javascript_debugger" = "yes"])
868AM_CONDITIONAL([ENABLE_OFFLINE_WEB_APPLICATIONS],[test "$enable_offline_web_applications" = "yes"]) 925AM_CONDITIONAL([ENABLE_OFFLINE_WEB_APPLICATIONS],[test "$enable_offline_web_applications" = "yes"])
926AM_CONDITIONAL([ENABLE_DIRECTORY_UPLOAD],[test "$enable_directory_upload" = "yes"])
869AM_CONDITIONAL([ENABLE_DOM_STORAGE],[test "$enable_dom_storage" = "yes"]) 927AM_CONDITIONAL([ENABLE_DOM_STORAGE],[test "$enable_dom_storage" = "yes"])
870AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"]) 928AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
871AM_CONDITIONAL([ENABLE_DATALIST],[test "$enable_datalist" = "yes"]) 929AM_CONDITIONAL([ENABLE_DATALIST],[test "$enable_datalist" = "yes"])
872AM_CONDITIONAL([ENABLE_EVENTSOURCE],[test "$enable_eventsource" = "yes"]) 930AM_CONDITIONAL([ENABLE_EVENTSOURCE],[test "$enable_eventsource" = "yes"])
873AM_CONDITIONAL([ENABLE_FAST_MOBILE_SCROLLING],[test "$enable_fast_mobile_scrolling" = "yes"]) 931AM_CONDITIONAL([ENABLE_FAST_MOBILE_SCROLLING],[test "$enable_fast_mobile_scrolling" = "yes"])
932AM_CONDITIONAL([ENABLE_FILE_SYSTEM],[test "$enable_file_system" = "yes"])
874AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"]) 933AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
875AM_CONDITIONAL([ENABLE_IMAGE_RESIZER],[test "$enable_image_resizer" = "yes"]) 934AM_CONDITIONAL([ENABLE_IMAGE_RESIZER],[test "$enable_image_resizer" = "yes"])
876AM_CONDITIONAL([ENABLE_INDEXED_DATABASE],[test "$enable_indexed_database" = "yes"]) 935AM_CONDITIONAL([ENABLE_INDEXED_DATABASE],[test "$enable_indexed_database" = "yes"])
@@ -879,12 +938,8 @@ AM_CONDITIONAL([ENABLE_XHTMLMP],[test "$enable_xhtmlmp" = "yes"])
879AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"]) 938AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
880AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"]) 939AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"])
881AM_CONDITIONAL([ENABLE_FILTERS],[test "$enable_filters" = "yes"]) 940AM_CONDITIONAL([ENABLE_FILTERS],[test "$enable_filters" = "yes"])
882AM_CONDITIONAL([ENABLE_FILE_READER],[test "$enable_file_reader" = "yes"])
883AM_CONDITIONAL([ENABLE_FILE_WRITER],[test "$enable_file_writer" = "yes"])
884AM_CONDITIONAL([ENABLE_GEOLOCATION], [test "$enable_geolocation" = "yes"]) 941AM_CONDITIONAL([ENABLE_GEOLOCATION], [test "$enable_geolocation" = "yes"])
885AM_CONDITIONAL([ENABLE_MATHML], [test "$enable_mathml" = "yes"]) 942AM_CONDITIONAL([ENABLE_MATHML], [test "$enable_mathml" = "yes"])
886AM_CONDITIONAL([ENABLE_RUBY],[test "$enable_ruby" = "yes"])
887AM_CONDITIONAL([ENABLE_SANDBOX],[test "$enable_sandbox" = "yes"])
888AM_CONDITIONAL([ENABLE_VIDEO],[test "$enable_video" = "yes"]) 943AM_CONDITIONAL([ENABLE_VIDEO],[test "$enable_video" = "yes"])
889AM_CONDITIONAL([ENABLE_NOTIFICATIONS],[test "$enable_notifications" = "yes"]) 944AM_CONDITIONAL([ENABLE_NOTIFICATIONS],[test "$enable_notifications" = "yes"])
890AM_CONDITIONAL([ENABLE_ORIENTATION_EVENTS],[test "$enable_orientation_events" = "yes"]) 945AM_CONDITIONAL([ENABLE_ORIENTATION_EVENTS],[test "$enable_orientation_events" = "yes"])
@@ -903,6 +958,7 @@ AM_CONDITIONAL([SVG_FLAGS],[test "$svg_flags" = "yes"])
903AM_CONDITIONAL([HTML_FLAGS],[test "$html_flags" = "yes"]) 958AM_CONDITIONAL([HTML_FLAGS],[test "$html_flags" = "yes"])
904AM_CONDITIONAL([ENABLE_WEB_SOCKETS],[test "$enable_web_sockets" = "yes"]) 959AM_CONDITIONAL([ENABLE_WEB_SOCKETS],[test "$enable_web_sockets" = "yes"])
905AM_CONDITIONAL([ENABLE_WEB_TIMING],[test "$enable_web_timing" = "yes"]) 960AM_CONDITIONAL([ENABLE_WEB_TIMING],[test "$enable_web_timing" = "yes"])
961AM_CONDITIONAL([ENABLE_OPCODE_STATS],[test "$enable_opcode_stats" = "yes"])
906 962
907# Gtk conditionals 963# Gtk conditionals
908AM_CONDITIONAL([ENABLE_INTROSPECTION],[test "$enable_introspection" = "yes"]) 964AM_CONDITIONAL([ENABLE_INTROSPECTION],[test "$enable_introspection" = "yes"])
@@ -918,7 +974,9 @@ WebKit/gtk/docs/version.xml
918 974
919AC_CONFIG_FILES([ 975AC_CONFIG_FILES([
920WebKit/gtk/${WEBKITGTK_PC_NAME}-${WEBKITGTK_API_VERSION}.pc:WebKit/gtk/webkit.pc.in 976WebKit/gtk/${WEBKITGTK_PC_NAME}-${WEBKITGTK_API_VERSION}.pc:WebKit/gtk/webkit.pc.in
921WebKit/gtk/JSCore-${WEBKITGTK_API_VERSION}.gir:WebKit/gtk/JSCore.gir.in] 977WebKit/gtk/JSCore-${WEBKITGTK_API_VERSION}.gir:WebKit/gtk/JSCore.gir.in
978WebKit/gtk/org.webkitgtk-${WEBKITGTK_API_VERSION}.gschema.xml:WebKit/gtk/org.webkitgtk.gschema.xml.in
979]
922,[WEBKITGTK_API_VERSION=$WEBKITGTK_API_VERSION,WEBKITGTK_PC_NAME=$WEBKITGTK_PC_NAME] 980,[WEBKITGTK_API_VERSION=$WEBKITGTK_API_VERSION,WEBKITGTK_PC_NAME=$WEBKITGTK_PC_NAME]
923) 981)
924 982
@@ -936,12 +994,11 @@ Build configuration:
936 Optimized memory allocator : $enable_fast_malloc 994 Optimized memory allocator : $enable_fast_malloc
937Features: 995Features:
938 3D Transforms : $enable_3D_transforms 996 3D Transforms : $enable_3D_transforms
939 Blob.slice support : $enable_blob_slice 997 Blob support : $enable_blob
998 Directory upload : $enable_directory_upload
940 Fast Mobile Scrolling : $enable_fast_mobile_scrolling 999 Fast Mobile Scrolling : $enable_fast_mobile_scrolling
941 JIT compilation : $enable_jit 1000 JIT compilation : $enable_jit
942 Filters support : $enable_filters 1001 Filters support : $enable_filters
943 FileReader support : $enable_file_reader
944 FileWriter support : $enable_file_writer
945 Geolocation support : $enable_geolocation 1002 Geolocation support : $enable_geolocation
946 JavaScript debugger/profiler support : $enable_javascript_debugger 1003 JavaScript debugger/profiler support : $enable_javascript_debugger
947 MathML support : $enable_mathml 1004 MathML support : $enable_mathml
@@ -949,12 +1006,14 @@ Features:
949 HTML5 channel messaging support : $enable_channel_messaging 1006 HTML5 channel messaging support : $enable_channel_messaging
950 HTML5 client-side session and persistent storage support : $enable_dom_storage 1007 HTML5 client-side session and persistent storage support : $enable_dom_storage
951 HTML5 client-side database storage support : $enable_database 1008 HTML5 client-side database storage support : $enable_database
952 HTML5 ruby support : $enable_ruby 1009 HTML5 FileSystem API support : $enable_file_system
953 HTML5 sandboxed iframe support : $enable_sandbox 1010 HTML5 sandboxed iframe support : $enable_sandbox
954 HTML5 server-sent events support : $enable_eventsource 1011 HTML5 server-sent events support : $enable_eventsource
955 HTML5 video element support : $enable_video 1012 HTML5 video element support : $enable_video
956 Icon database support : $enable_icon_database 1013 Icon database support : $enable_icon_database
957 Image resizer support : $enable_image_resizer 1014 Image resizer support : $enable_image_resizer
1015 Link prefetch support : $enable_link_prefetch
1016 Opcode stats : $enable_opcode_stats
958 SharedWorkers support : $enable_shared_workers 1017 SharedWorkers support : $enable_shared_workers
959 Speech input support : $enable_input_speech 1018 Speech input support : $enable_input_speech
960 SVG support : $enable_svg 1019 SVG support : $enable_svg
@@ -970,6 +1029,7 @@ Features:
970 XHTML-MP support : $enable_xhtmlmp 1029 XHTML-MP support : $enable_xhtmlmp
971 XPATH support : $enable_xpath 1030 XPATH support : $enable_xpath
972 XSLT support : $enable_xslt 1031 XSLT support : $enable_xslt
1032
973GTK+ configuration: 1033GTK+ configuration:
974 GTK+ version : $with_gtk 1034 GTK+ version : $with_gtk
975 GDK target : $with_target 1035 GDK target : $with_target