summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/files/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/files/configure.ac')
-rw-r--r--meta/recipes-sato/webkit/files/configure.ac983
1 files changed, 983 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/files/configure.ac b/meta/recipes-sato/webkit/files/configure.ac
new file mode 100644
index 0000000000..d4f3e749fc
--- /dev/null
+++ b/meta/recipes-sato/webkit/files/configure.ac
@@ -0,0 +1,983 @@
1AC_PREREQ(2.59)
2
3m4_define([webkit_major_version], [1])
4m4_define([webkit_minor_version], [3])
5m4_define([webkit_micro_version], [2])
6
7# This is the version we'll be using as part of our User-Agent string
8# e.g., AppleWebKit/$(webkit_user_agent_version) ...
9#
10# Sourced from WebCore/Configurations/Version.xcconfig
11m4_define([webkit_user_agent_major_version], [531])
12m4_define([webkit_user_agent_minor_version], [2])
13
14AC_INIT([WebKit],[webkit_major_version.webkit_minor_version.webkit_micro_version],[http://bugs.webkit.org/])
15
16AC_CONFIG_MACRO_DIR([autotools])
17AC_CONFIG_AUX_DIR([autotools])
18AC_SUBST(ACLOCAL_AMFLAGS, "-I autotools")
19
20AC_CONFIG_HEADERS([autotoolsconfig.h])
21AC_CANONICAL_HOST
22
23WEBKIT_MAJOR_VERSION=webkit_major_version
24WEBKIT_MINOR_VERSION=webkit_minor_version
25WEBKIT_MICRO_VERSION=webkit_micro_version
26WEBKIT_USER_AGENT_MAJOR_VERSION=webkit_user_agent_major_version
27WEBKIT_USER_AGENT_MINOR_VERSION=webkit_user_agent_minor_version
28AC_SUBST(WEBKIT_MAJOR_VERSION)
29AC_SUBST(WEBKIT_MINOR_VERSION)
30AC_SUBST(WEBKIT_MICRO_VERSION)
31AC_SUBST(WEBKIT_USER_AGENT_MAJOR_VERSION)
32AC_SUBST(WEBKIT_USER_AGENT_MINOR_VERSION)
33
34AC_CONFIG_SRCDIR([WebCore/config.h])
35
36dnl # Libtool library version, not to confuse with API version
37dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html#Libtool-versioning
38LIBWEBKITGTK_VERSION=0:0:0
39AC_SUBST([LIBWEBKITGTK_VERSION])
40
41AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
42
43# Use AM_SILENT_RULES if present
44m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
45
46# host checking - inspired by the GTK+ configure.in
47# TODO: move these to webkit.m4?
48AC_MSG_CHECKING([for native Win32])
49case "$host" in
50 *-*-mingw*)
51 os_win32=yes
52 ;;
53 *)
54 os_win32=no
55 ;;
56esac
57AC_MSG_RESULT([$os_win32])
58
59case "$host" in
60 *-*-linux*)
61 os_linux=yes
62 ;;
63 *-*-freebsd*)
64 os_freebsd=yes
65 ;;
66 *-*-darwin*)
67 os_darwin=yes
68 ;;
69esac
70
71case "$host_os" in
72 gnu* | linux* | k*bsd*-gnu)
73 os_gnu=yes
74 ;;
75 *)
76 os_gnu=no
77 ;;
78esac
79
80# initialize webkit options
81WEBKIT_INIT
82AC_DISABLE_STATIC
83AC_LIBTOOL_WIN32_DLL
84AC_PROG_LIBTOOL
85
86AC_PATH_PROG(FLEX, flex)
87if test -z "$FLEX"; then
88 AC_MSG_ERROR([You need the 'flex' lexer generator to compile WebKit])
89else
90 FLEX_VERSION=`$FLEX --version | sed 's,.*\ \([0-9]*\.[0-9]*\.[0-9]*\)$,\1,'`
91 AX_COMPARE_VERSION([2.5.33],[gt],[$FLEX_VERSION],
92 AC_MSG_WARN([You need at least version 2.5.33 of the 'flex' lexer generator to compile WebKit correctly]))
93fi
94
95AC_PATH_PROG(GPERF, gperf)
96if test -z "$GPERF"; then
97 AC_MSG_ERROR([You need the 'gperf' hash function generator to compile WebKit])
98fi
99
100# pthread (not needed on Windows)
101if test "$os_win32" = "no"; then
102AC_CHECK_HEADERS([pthread.h],
103 AC_DEFINE([HAVE_PTHREAD_H],[1],[Define if pthread exists]),
104 AC_MSG_ERROR([pthread support is required to build WebKit]))
105fi
106
107# check for libjpeg the way Gtk does it.
108AC_CHECK_LIB(jpeg, jpeg_destroy_decompress,
109 jpeg_ok=yes, jpeg_ok=no
110 AC_MSG_ERROR([JPEG library (libjpeg) not found]))
111if test "$jpeg_ok" = yes; then
112 AC_MSG_CHECKING([for jpeglib])
113 AC_TRY_CPP(
114[#include <stdio.h>
115#undef PACKAGE
116#undef VERSION
117#undef HAVE_STDLIB_H
118#include <jpeglib.h>],
119 jpeg_ok=yes,
120 jpeg_ok=no)
121 AC_MSG_RESULT($jpeg_ok)
122 if test "$jpeg_ok" = yes; then
123 JPEG_LIBS="-ljpeg"
124 # should we check for progressive JPEG like GTK+ as well?
125 else
126 AC_MSG_ERROR([JPEG library (libjpeg) not found])
127 fi
128fi
129AC_SUBST([JPEG_LIBS])
130
131# Check for libpng the way Gtk+ does it
132for l in libpng libpng14 libpng12; do
133 AC_MSG_CHECKING(for $l)
134 if $PKG_CONFIG --exists $l ; then
135 AC_MSG_RESULT(yes)
136 PNG_LIBS=`$PKG_CONFIG --libs $l`
137 png_ok=yes
138 break
139 else
140 AC_MSG_RESULT(no)
141 png_ok=no
142 fi
143done
144if test "$png_ok" != yes; then
145 AC_CHECK_LIB(png, png_read_info,
146 [AC_CHECK_HEADER(png.h,
147 png_ok=yes,
148 png_ok=no)],
149 AC_MSG_ERROR([PNG library (libpng) not found]), -lz -lm)
150 if test "$png_ok" = yes; then
151 AC_MSG_CHECKING([for png_structp in png.h])
152 AC_TRY_COMPILE([#include <png.h>],
153 [png_structp pp; png_infop info; png_colorp cmap; png_create_read_struct;],
154 png_ok=yes,
155 png_ok=no)
156 AC_MSG_RESULT($png_ok)
157 if test "$png_ok" = yes; then
158 PNG_LIBS='-lpng -lz'
159 else
160 AC_MSG_ERROR([PNG library (libpng) not found])
161 fi
162 else
163 AC_MSG_ERROR([PNG library (libpng) not found])
164 fi
165fi
166AC_SUBST([PNG_LIBS])
167
168# determine the GTK+ version to use
169AC_MSG_CHECKING([the GTK+ version to use])
170AC_ARG_WITH([gtk],
171 [AS_HELP_STRING([--with-gtk=2.0|3.0], [the GTK+ version to use (default: 2.0)])],
172 [case "$with_gtk" in
173 2.0|3.0) ;;
174 *) AC_MSG_ERROR([invalid GTK+ version specified]) ;;
175 esac],
176 [with_gtk=2.0])
177AC_MSG_RESULT([$with_gtk])
178
179case "$with_gtk" in
180 2.0) GTK_REQUIRED_VERSION=2.10
181 GTK_API_VERSION=2.0
182 WEBKITGTK_API_MAJOR_VERSION=1
183 WEBKITGTK_API_MINOR_VERSION=0
184 WEBKITGTK_API_VERSION=1.0
185 WEBKITGTK_PC_NAME=webkit
186 GAIL_PC_NAME=gail
187 GAIL_REQUIRED_VERSION=1.8
188 ;;
189 3.0) GTK_REQUIRED_VERSION=2.90
190 GTK_API_VERSION=3.0
191 WEBKITGTK_API_MAJOR_VERSION=3
192 WEBKITGTK_API_MINOR_VERSION=0
193 WEBKITGTK_API_VERSION=3.0
194 WEBKITGTK_PC_NAME=webkitgtk
195 GAIL_PC_NAME=gail-3.0
196 GAIL_REQUIRED_VERSION=2.90.4
197 ;;
198esac
199
200AC_SUBST([WEBKITGTK_API_MAJOR_VERSION])
201AC_SUBST([WEBKITGTK_API_MINOR_VERSION])
202AC_SUBST([WEBKITGTK_API_VERSION])
203AC_SUBST([WEBKITGTK_PC_NAME])
204AC_SUBST([GTK_API_VERSION])
205AM_CONDITIONAL([GTK_API_VERSION_2],[test "$GTK_API_VERSION" = "2.0"])
206
207# determine the GDK/GTK+ target
208AC_MSG_CHECKING([the target windowing system])
209AC_ARG_WITH(target,
210 AC_HELP_STRING([--with-target=@<:@x11/win32/quartz/directfb@:>@],
211 [Select webkit target [default=x11]]),
212 [],[with_target="x11"])
213
214case "$with_target" in
215 x11|win32|quartz|directfb) ;;
216 *) AC_MSG_ERROR([Invalid target: must be x11, quartz, win32, or directfb.]) ;;
217esac
218
219AC_MSG_RESULT([$with_target])
220
221AC_MSG_CHECKING([for Hildon UI extensions])
222AC_ARG_WITH(hildon,
223 AC_HELP_STRING([--with-hildon],
224 [Use Hildon UI extensions [default=no]]),
225 [],[with_hildon="no"])
226AC_MSG_RESULT([$with_hildon])
227
228if test "$with_hildon" = "yes"; then
229 HILDON_CPPFLAGS="-DMAEMO_CHANGES"
230 PKG_CHECK_MODULES([HILDON], [hildon-1])
231 AC_SUBST([HILDON_CPPFLAGS])
232 AC_SUBST([HILDON_CFLAGS])
233 AC_SUBST([HILDON_LIBS])
234fi
235
236# minimum base dependencies
237LIBSOUP_REQUIRED_VERSION=2.28.2
238CAIRO_REQUIRED_VERSION=1.6
239FONTCONFIG_REQUIRED_VERSION=2.4
240FREETYPE2_REQUIRED_VERSION=9.0
241LIBXML_REQUIRED_VERSION=2.6
242
243# minimum GTK+ base dependencies
244PANGO_REQUIRED_VERSION=1.12
245
246# optional modules
247LIBXSLT_REQUIRED_VERSION=1.1.7
248SQLITE_REQUIRED_VERSION=3.0
249GSTREAMER_REQUIRED_VERSION=0.10
250GSTREAMER_PLUGINS_BASE_REQUIRED_VERSION=0.10.25
251ENCHANT_REQUIRED_VERSION=0.22
252
253# Available modules
254#
255# glib - glib and includes gthread
256# unicode - check and identify which unicode backend to use
257#
258# todo: webcore gtk
259WEBKIT_CHECK_DEPENDENCIES([glib unicode])
260
261GETTEXT_PACKAGE=$PACKAGE
262AC_SUBST(GETTEXT_PACKAGE)
263AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",
264 [The gettext catalog name])
265
266PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_REQUIRED_VERSION)
267AC_SUBST(LIBXML_CFLAGS)
268AC_SUBST(LIBXML_LIBS)
269
270PKG_CHECK_MODULES(PANGO,
271 [pango >= $PANGO_REQUIRED_VERSION
272 pangoft2])
273AC_SUBST(PANGO_CFLAGS)
274AC_SUBST(PANGO_LIBS)
275
276PKG_CHECK_MODULES(ENCHANT, enchant >= $ENCHANT_REQUIRED_VERSION)
277AC_SUBST(ENCHANT_CFLAGS)
278AC_SUBST(ENCHANT_LIBS)
279
280PKG_CHECK_MODULES(GAIL, $GAIL_PC_NAME >= $GAIL_REQUIRED_VERSION)
281AC_SUBST(GAIL_CFLAGS)
282AC_SUBST(GAIL_LIBS)
283
284# check for target-specific dependencies
285if test "$with_target" = "directfb"; then
286 PKG_CHECK_MODULES(CAIRO, cairo-directfb >= $CAIRO_REQUIRED_VERSION)
287 PKG_CHECK_MODULES(GTK, gtk+-directfb-2.0 >= $GTK_REQUIRED_VERSION)
288 AC_DEFINE([WTF_PLATFORM_DIRECTFB],[1],[Define if target is DirectFB])
289else
290 PKG_CHECK_MODULES(CAIRO, cairo >= $CAIRO_REQUIRED_VERSION)
291 PKG_CHECK_MODULES(GTK, gtk+-$GTK_API_VERSION >= $GTK_REQUIRED_VERSION)
292
293 if test "$with_target" = "x11" && test "$os_win32" = "no"; then
294 # check for XT
295 PKG_CHECK_MODULES([XT],
296 [xt],
297 [xt_has_pkg_config=yes],
298 [xt_has_pkg_config=no])
299 # some old versions of Xt do not provide xt.pc, so try to link against Xt
300 # and if it's installed fall back to just adding -lXt
301 if test "$xt_has_pkg_config" = "no"; then
302 # using AC_CHECK_LIB instead of AC_SEARCH_LIB is fine in this case as
303 # we don't care about the XtOpenDisplay symbol but only about the
304 # existence of libXt
305 AC_CHECK_LIB([Xt], [XtOpenDisplay],
306 [XT_CFLAGS=""; XT_LIBS="-lXt"],
307 [AC_MSG_ERROR([X Toolkit Intrinsics library (libXt) not found])])
308 fi
309 AC_SUBST([XT_CFLAGS])
310 AC_SUBST([XT_LIBS])
311 AC_DEFINE([WTF_PLATFORM_X11],[1],[Define if target is X11])
312 fi
313fi
314AC_SUBST(GTK_CFLAGS)
315AC_SUBST(GTK_LIBS)
316AC_SUBST(CAIRO_CFLAGS)
317AC_SUBST(CAIRO_LIBS)
318
319# check whether to build with debugging enabled
320AC_MSG_CHECKING([whether to do a debug build])
321AC_ARG_ENABLE(debug,
322 AC_HELP_STRING([--enable-debug],
323 [turn on debugging [default=no]]),
324 [],[enable_debug="no"])
325AC_MSG_RESULT([$enable_debug])
326
327# check whether to enable optimized builds
328AC_MSG_CHECKING([whether to enable optimized builds])
329AC_ARG_ENABLE(optimizations,
330 AC_HELP_STRING([--enable-optimizations],
331 [turn on optimize builds (GCC only)
332 [default=yes]]),
333 [enable_optimizations=$enableval],
334 [if test "$enable_debug" = "yes"; then enable_optimizations="no"; else enable_optimizations="yes"; fi])
335AC_MSG_RESULT([$enable_optimizations])
336
337# check whether to enable 3D transforms support
338AC_MSG_CHECKING([whether to enable support for 3D Transforms])
339AC_ARG_ENABLE(3D_transforms,
340 AC_HELP_STRING([--enable-3D-transforms],
341 [enable support for 3D transforms [default=no]]),
342 [],[enable_3D_transforms="no"])
343AC_MSG_RESULT([$enable_3D_transforms])
344
345# check whether to enable channel messaging support
346AC_MSG_CHECKING([whether to enable HTML5 Channel Messaging support])
347AC_ARG_ENABLE(channel_messaging,
348 AC_HELP_STRING([--enable-channel-messaging],
349 [enable HTML5 channel messaging support [default=yes]]),
350 [],[enable_channel_messaging="yes"])
351AC_MSG_RESULT([$enable_channel_messaging])
352
353# check whether to enable JavaScript debugger/profiler support
354AC_MSG_CHECKING([whether to enable JavaScript debugger/profiler support])
355AC_ARG_ENABLE(javascript_debugger,
356 AC_HELP_STRING([--enable-javascript-debugger],
357 [enable JavaScript debugger/profiler support [default=yes]]),
358 [],[enable_javascript_debugger="yes"])
359AC_MSG_RESULT([$enable_javascript_debugger])
360
361# check whether to enable HTML5 Offline Web Applications support
362AC_MSG_CHECKING([whether to enable HTML5 offline web applications support])
363AC_ARG_ENABLE(offline_web_applications,
364 AC_HELP_STRING([--enable-offline-web-applications],
365 [enable HTML5 offline web applications support [default=yes]]),
366 [],[enable_offline_web_applications="yes"])
367AC_MSG_RESULT([$enable_offline_web_applications])
368
369# check whether to enable HTML5 client-side session and persitent storage support
370AC_MSG_CHECKING([whether to enable HTML5 client-side session and persistent storage support])
371AC_ARG_ENABLE(dom_storage,
372 AC_HELP_STRING([--enable-dom-storage],
373 [enable HTML5 client-side session and persistent storage support [default=yes]]),
374 [],[enable_dom_storage="yes"])
375AC_MSG_RESULT([$enable_dom_storage])
376
377# check whether to enable the indexed database API
378AC_MSG_CHECKING([whether to enable the indexed database API])
379AC_ARG_ENABLE(indexed_database,
380 AC_HELP_STRING([--enable-indexeddb],
381 [enable the indexed database API [default=no]]),
382 [],[enable_indexed_database="no"])
383AC_MSG_RESULT([$enable_indexed_database])
384
385# check whether to enable the speech input API
386AC_MSG_CHECKING([whether to enable the speech input API])
387AC_ARG_ENABLE(input_speech,
388 AC_HELP_STRING([--enable-input-speech],
389 [enable the speech input API [default=no]]),
390 [],[enable_input_speech="no"])
391AC_MSG_RESULT([$enable_input_speech])
392
393# check whether to build with database support
394AC_MSG_CHECKING([whether to enable HTML5 client-side database storage support])
395AC_ARG_ENABLE(database,
396 AC_HELP_STRING([--enable-database],
397 [enable HTML5 client-side database storage support [default=yes]]),
398 [],[enable_database="yes"])
399AC_MSG_RESULT([$enable_database])
400
401# check whether to build with server-sent events support
402AC_MSG_CHECKING([whether to enable HTML5 server-sent events support])
403AC_ARG_ENABLE(eventsource,
404 AC_HELP_STRING([--enable-eventsource],
405 [enable HTML5 server-sent events support [default=yes]]),
406 [],[enable_eventsource="yes"])
407AC_MSG_RESULT([$enable_eventsource])
408
409# check whether to build with icon database support
410AC_MSG_CHECKING([whether to enable icon database support])
411AC_ARG_ENABLE(icon_database,
412 AC_HELP_STRING([--enable-icon-database],
413 [enable icon database [default=yes]]),
414 [],[enable_icon_database="yes"])
415AC_MSG_RESULT([$enable_icon_database])
416
417# check whether to build with image resizer API support
418AC_MSG_CHECKING([whether to enable image resizer API support])
419AC_ARG_ENABLE(image_resizer,
420 AC_HELP_STRING([--enable-image-resizer],
421 [enable image resizer [default=no]]),
422 [],[enable_image_resizer="no"])
423AC_MSG_RESULT([$enable_image_resizer])
424
425# check whether to enable HTML5 datalist support
426AC_MSG_CHECKING([whether to enable HTML5 datalist support])
427AC_ARG_ENABLE(datalist,
428 AC_HELP_STRING([--enable-datalist],
429 [enable HTML5 datalist support [default=yes]]),
430 [],[enable_datalist="yes"])
431AC_MSG_RESULT([$enable_datalist])
432
433# check whether to enable HTML5 ruby support
434AC_MSG_CHECKING([whether to enable HTML5 ruby support])
435AC_ARG_ENABLE(ruby,
436 AC_HELP_STRING([--enable-ruby],
437 [enable HTML5 ruby support [default=yes]]),
438 [],[enable_ruby="yes"])
439AC_MSG_RESULT([$enable_ruby])
440
441# check whether to enable HTML5 sandbox iframe support
442AC_MSG_CHECKING([whether to enable HTML5 sandboxed iframe support])
443AC_ARG_ENABLE(sandbox,
444 AC_HELP_STRING([--enable-sandbox],
445 [enable HTML5 sandboxed iframe support [default=yes]]),
446 [],[enable_sandbox="yes"])
447AC_MSG_RESULT([$enable_sandbox])
448
449# check whether to enable HTML5 audio/video support
450AC_MSG_CHECKING([whether to enable HTML5 video support])
451AC_ARG_ENABLE(video,
452 AC_HELP_STRING([--enable-video],
453 [enable HTML5 video support [default=yes]]),
454 [],[enable_video="yes"])
455AC_MSG_RESULT([$enable_video])
456
457# check whether to enable XHTML-MP support
458AC_MSG_CHECKING([whether to enable XHTML-MP support])
459AC_ARG_ENABLE(xhtmlmp,
460 AC_HELP_STRING([--enable-xhtmlmp],
461 [enable support for XHTML-MP [default=no]]),
462 [],[enable_xhtmlmp="no"])
463AC_MSG_RESULT([$enable_xhtmlmp])
464
465# check whether to enable XPath support
466AC_MSG_CHECKING([whether to enable XPath support])
467AC_ARG_ENABLE(xpath,
468 AC_HELP_STRING([--enable-xpath],
469 [enable support for XPath [default=yes]]),
470 [],[enable_xpath="yes"])
471AC_MSG_RESULT([$enable_xpath])
472
473# check whether to enable XSLT support
474AC_MSG_CHECKING([whether to enable XSLT support])
475AC_ARG_ENABLE(xslt,
476 AC_HELP_STRING([--enable-xslt],
477 [enable support for XSLT [default=yes]]),
478 [],[enable_xslt="yes"])
479AC_MSG_RESULT([$enable_xslt])
480
481# check whether to enable geolocation support
482AC_MSG_CHECKING([whether to enable geolocation support])
483AC_ARG_ENABLE(geolocation,
484 AC_HELP_STRING([--enable-geolocation],
485 [enable support for geolocation [default=no]]),
486 [],[enable_geolocation="no"])
487AC_MSG_RESULT([$enable_geolocation])
488
489# check whether to enable MathML support
490AC_MSG_CHECKING([whether to enable MathML support])
491AC_ARG_ENABLE(mathml,
492 AC_HELP_STRING([--enable-mathml],
493 [enable support for MathML [default=no]]),
494 [],[enable_mathml="no"])
495AC_MSG_RESULT([$enable_mathml])
496
497# check whether to enable SVG support
498AC_MSG_CHECKING([whether to enable SVG support])
499AC_ARG_ENABLE(svg,
500 AC_HELP_STRING([--enable-svg],
501 [enable support for SVG [default=yes]]),
502 [],[enable_svg="yes"])
503AC_MSG_RESULT([$enable_svg])
504
505# check whether to enable WML support
506AC_MSG_CHECKING([whether to enable WML support])
507AC_ARG_ENABLE(wml,
508 AC_HELP_STRING([--enable-wml],
509 [enable support for WML [default=no]]),
510 [],[enable_wml="no"])
511AC_MSG_RESULT([$enable_wml])
512
513# check whether to enable SharedWorkers support
514AC_MSG_CHECKING([whether to enable SharedWorkers support])
515AC_ARG_ENABLE(shared_workers,
516 AC_HELP_STRING([--enable-shared-workers],
517 [enable support for SharedWorkers [default=yes]]),
518 [],[enable_shared_workers="yes"])
519AC_MSG_RESULT([$enable_shared_workers])
520
521# check whether to enable Web Workers support
522AC_MSG_CHECKING([whether to enable Web Workers support])
523AC_ARG_ENABLE(workers,
524 AC_HELP_STRING([--enable-workers],
525 [enable support for Web Workers [default=yes]]),
526 [],[enable_workers="yes"])
527AC_MSG_RESULT([$enable_workers])
528
529# turn off svg features if --disable-svg is requested
530if test "$enable_svg" = "no"; then
531 enable_svg_animation=no
532 enable_svg_fonts=no
533 enable_svg_foreign_object=no
534 enable_svg_as_image=no
535 enable_svg_use=no
536fi
537
538# check whether to enable support for SVG animation
539AC_MSG_CHECKING([whether to enable support for SVG animation])
540AC_ARG_ENABLE(svg_animation,
541 AC_HELP_STRING([--enable-svg-animation],
542 [enable support for SVG animation (experimental) [default=yes]]),
543 [],[enable_svg_animation="yes"])
544AC_MSG_RESULT([$enable_svg_animation])
545
546# check whether to enable support for filters
547AC_MSG_CHECKING([whether to enable support for filters])
548AC_ARG_ENABLE(filters,
549 AC_HELP_STRING([--enable-filters],
550 [enable support for filters (experimental) [default=yes]]),
551 [],[enable_filters="yes"])
552AC_MSG_RESULT([$enable_filters])
553
554# check whether to enable support for SVG fonts
555AC_MSG_CHECKING([whether to enable support for SVG fonts])
556AC_ARG_ENABLE(svg_fonts,
557 AC_HELP_STRING([--enable-svg-fonts],
558 [enable support for SVG fonts (experimental) [default=yes]]),
559 [],[enable_svg_fonts="yes"])
560AC_MSG_RESULT([$enable_svg_fonts])
561
562# check whether to enable foreign objects support for SVG
563AC_MSG_CHECKING([whether to enable support for SVG foreign objects])
564AC_ARG_ENABLE(svg_foreign_object,
565 AC_HELP_STRING([--enable-svg-foreign-object],
566 [enable support for SVG foreign objects (experimental) [default=yes]]),
567 [],[enable_svg_foreign_object="yes"])
568AC_MSG_RESULT([$enable_svg_foreign_object])
569
570# check whether to enable SVG As Image support
571AC_MSG_CHECKING([whether to enable SVG as Image support])
572AC_ARG_ENABLE(svg_as_image,
573 AC_HELP_STRING([--enable-svg-as-image],
574 [enable SVG as Image support (experimental) [default=yes]]),
575 [],[enable_svg_as_image="yes"])
576AC_MSG_RESULT([$enable_svg_as_image])
577
578# check whether to enable SVG USE element support
579AC_MSG_CHECKING([whether to enable support for SVG use element])
580AC_ARG_ENABLE(svg_use,
581 AC_HELP_STRING([--enable-svg-use],
582 [enable SVG use element support (experimental) [default=yes]]),
583 [],[enable_svg_use="yes"])
584AC_MSG_RESULT([$enable_svg_use])
585
586# check for SVG features, enabling SVG if necessary
587if test "$enable_svg_animation" = "yes" || \
588 test "$enable_svg_fonts" = "yes" || \
589 test "$enable_svg_foreign_object" = "yes" || \
590 test "$enable_svg_as_image" = "yes" || \
591 test "$enable_svg_use" = "yes"; then
592 svg_flags=yes
593 if test "$enable_svg" = "no"; then
594 AC_MSG_WARN([SVG feature(s) requested but SVG is disabled.. Enabling SVG support])
595 enable_svg=yes
596 fi
597fi
598
599# check whether to enable Web Socket support
600AC_MSG_CHECKING([whether to enable Web Sockets support])
601AC_ARG_ENABLE(web_sockets,
602 AC_HELP_STRING([--enable-web-sockets],
603 [enable support for Web Sockets [default=no]]),
604 [],[enable_web_sockets="no"])
605AC_MSG_RESULT([$enable_web_sockets])
606
607# check whether to enable Web Timing support
608AC_MSG_CHECKING([whether to enable Web Timing support])
609AC_ARG_ENABLE(web_timing,
610 AC_HELP_STRING([--enable-web-timing],
611 [enable support for Web Timing [default=no]]),
612 [],[enable_web_timing="no"])
613AC_MSG_RESULT([$enable_web_timing])
614
615# check whether to enable Blob.slice support
616AC_MSG_CHECKING([whether to enable Blob.slice support])
617AC_ARG_ENABLE(blob_slice,
618 AC_HELP_STRING([--enable-blob-slice],
619 [enable support for Blob.slice [default=no]]),
620 [],[enable_blob_slice="no"])
621AC_MSG_RESULT([$enable_blob_slice])
622
623# check whether to enable Fast Mobile Scrolling support
624AC_MSG_CHECKING([whether to enable Fast Mobile Scrolling])
625AC_ARG_ENABLE(fast_mobile_scrolling,
626 AC_HELP_STRING([--enable-fast-mobile-scrolling],
627 [enable support for Fast Mobile Scrolling [default=no]]),
628 [],[enable_fast_mobile_scrolling="no"])
629AC_MSG_RESULT([$enable_fast_mobile_scrolling])
630
631# check whether to enable FileReader support
632AC_MSG_CHECKING([whether to enable FileReader support])
633AC_ARG_ENABLE(file_reader,
634 AC_HELP_STRING([--enable-file-reader],
635 [enable support for FileReader [default=no]]),
636 [],[enable_file_reader="no"])
637AC_MSG_RESULT([$enable_file_reader])
638
639# check whether to enable FileWriter support
640AC_MSG_CHECKING([whether to enable FileWriter support])
641AC_ARG_ENABLE(file_writer,
642 AC_HELP_STRING([--enable-file-writer],
643 [enable support for FileWriter [default=no]]),
644 [],[enable_file_writer="no"])
645AC_MSG_RESULT([$enable_file_writer])
646
647# check whether to enable code coverage
648AC_MSG_CHECKING([whether to enable code coverage support])
649AC_ARG_ENABLE(coverage,
650 AC_HELP_STRING([--enable-coverage],
651 [enable code coverage support [default=no]]),
652 [],[enable_coverage="no"])
653AC_MSG_RESULT([$enable_coverage])
654
655# check whether to enable FastMalloc
656AC_MSG_CHECKING([whether to enable optimized memory allocator])
657AC_ARG_ENABLE(fast_malloc,
658 AC_HELP_STRING([--enable-fast-malloc],
659 [enable optimized memory allocator default=yes, default=no for debug builds]),
660 [],[if test "$enable_debug" = "yes"; then enable_fast_malloc="no"; else enable_fast_malloc="yes"; fi])
661AC_MSG_RESULT([$enable_fast_malloc])
662
663AC_MSG_CHECKING([whether to enable JIT compilation])
664AC_ARG_ENABLE([jit],
665 AC_HELP_STRING([--enable-jit],
666 [Enable JIT compilation default=yes]),
667 [],[enable_jit="yes"])
668if test "$enable_jit" = "yes"; then
669 case "$host_cpu" in
670 i*86|x86_64)
671 AC_DEFINE([ENABLE_JIT], [1], [Define to enable JIT])
672 AC_DEFINE([ENABLE_YARR], [1], [Define to enable YARR])
673 AC_DEFINE([ENABLE_YARR_JIT], [1], [Define to enable YARR JIT])
674 AC_DEFINE([ENABLE_JIT_OPTIMIZE_CALL], [1], [Define to enable optimizing calls])
675 AC_DEFINE([ENABLE_JIT_OPTIMIZE_PROPERTY_ACCESS], [1], [Define to enable optimized property access])
676 AC_DEFINE([ENABLE_JIT_OPTIMIZE_ARITHMETIC], [1], [Define to enable optimized arithmetic])
677 case "$host_cpu" in
678 i*86)
679 AC_DEFINE([WTF_USE_JIT_STUB_ARGUMENT_VA_LIST], [1], [Use stub va_list])
680 ;;
681 x86_64)
682 AC_DEFINE([WTF_USE_JIT_STUB_ARGUMENT_REGISTER], [1], [Use stub register])
683 AC_DEFINE([WTF_USE_ALTERNATE_JSIMMEDIATE], [1], [Use alternate JSImmediate])
684 ;;
685 esac
686 ;;
687 *)
688 enable_jit="no (CPU '$host_cpu' not supported)"
689 ;;
690 esac
691fi
692AC_MSG_RESULT([$enable_jit])
693
694# GObject Introspection
695AC_MSG_CHECKING([whether to enable GObject introspection support])
696AC_ARG_ENABLE([introspection],
697 [AS_HELP_STRING([--enable-introspection],[Enable GObject introspection (default: disabled)])],
698 [],[enable_introspection=no])
699AC_MSG_RESULT([$enable_introspection])
700
701G_IR_SCANNER=
702G_IR_COMPILER=
703G_IR_GENERATE=
704GIRDIR=
705GIRTYPELIBDIR=
706
707if test "$enable_introspection" = "yes"; then
708 GOBJECT_INTROSPECTION_REQUIRED=0.6.15
709 PKG_CHECK_MODULES([INTROSPECTION],[gobject-introspection-1.0 >= $GOBJECT_INTROSPECTION_REQUIRED])
710
711 G_IR_SCANNER="$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)"
712 G_IR_COMPILER="$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)"
713 G_IR_GENERATE="$($PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0)"
714 AC_DEFINE([ENABLE_INTROSPECTION],[1],[Define to enable GObject introspection support])
715fi
716
717AC_SUBST([G_IR_SCANNER])
718AC_SUBST([G_IR_COMPILER])
719AC_SUBST([G_IR_GENERATE])
720
721# determine the font backend
722AC_MSG_CHECKING([the font backend to use])
723AC_ARG_WITH(font_backend,
724 AC_HELP_STRING([--with-font-backend=@<:@freetype/pango@:>@],
725 [Select font backend [default=freetype]]),
726 [],[with_font_backend="freetype"])
727
728case "$with_font_backend" in
729 freetype|pango) ;;
730 *) AC_MSG_ERROR([Invalid font backend: must be freetype or pango.]) ;;
731esac
732AC_MSG_RESULT([$with_font_backend])
733
734# Add '-g' flag to gcc if it's debug build
735if test "$enable_debug" = "yes"; then
736 CXXFLAGS="$CXXFLAGS -g"
737 CFLAGS="$CFLAGS -g"
738else
739 AC_DEFINE([NDEBUG], [1], [Define to disable debugging features])
740fi
741
742# Add the appropriate 'O' level for optimized builds
743if test "$enable_optimizations" = "yes"; then
744 CXXFLAGS="$CXXFLAGS -O2"
745 CFLAGS="$CFLAGS -O2"
746else
747 CXXFLAGS="$CXXFLAGS -O0"
748 CFLAGS="$CFLAGS -O0"
749fi
750
751PKG_CHECK_MODULES([LIBSOUP],
752 [libsoup-2.4 >= $LIBSOUP_REQUIRED_VERSION])
753AC_SUBST([LIBSOUP_CFLAGS])
754AC_SUBST([LIBSOUP_LIBS])
755
756# check if we can use libSoup 2.29.90 features
757PKG_CHECK_MODULES([LIBSOUP_2_29_90],
758 [libsoup-2.4 >= 2.29.90],
759 [have_libsoup_2_29_90=yes],
760 [have_libsoup_2_29_90=no])
761if test "$have_libsoup_2_29_90" = "yes"; then
762 AC_DEFINE([HAVE_LIBSOUP_2_29_90], 1, [Whether libSoup 2.29.90 features are available])
763fi
764
765# check if FreeType/FontConfig are available
766if test "$with_font_backend" = "freetype"; then
767 if test "$with_target" = "directfb"; then
768 PKG_CHECK_MODULES([FREETYPE],
769 [fontconfig >= $FONTCONFIG_REQUIRED_VERSION
770 freetype2 >= $FREETYPE2_REQUIRED_VERSION])
771 else
772 PKG_CHECK_MODULES([FREETYPE],
773 [cairo-ft
774 fontconfig >= $FONTCONFIG_REQUIRED_VERSION
775 freetype2 >= $FREETYPE2_REQUIRED_VERSION])
776 fi
777 AC_SUBST([FREETYPE_CFLAGS])
778 AC_SUBST([FREETYPE_LIBS])
779fi
780
781# check if sqlite 3 is available
782if test "$enable_icon_database" = "yes" || \
783 test "$enable_database" = "yes" || \
784 test "$enable_offline_web_applications" = "yes" || \
785 test "$enable_dom_storage" = "yes"; then
786 PKG_CHECK_MODULES([SQLITE3],
787 [sqlite3 >= $SQLITE_REQUIRED_VERSION],
788 [sqlite3_has_pkg_config=yes],
789 [sqlite3_has_pkg_config=no])
790 if test "$sqlite3_has_pkg_config" = "no"; then
791 AC_SEARCH_LIBS([sqlite3_open16], [sqlite3],
792 [SQLITE3_LIBS="$LIBS";SQLITE3_CFLAGS="-I $srcdir/WebKitLibraries/WebCoreSQLite3"],
793 [AC_MSG_ERROR([SQLite3 is required to enable Database support])])
794 fi
795 AC_SUBST([SQLITE3_CFLAGS])
796 AC_SUBST([SQLITE3_LIBS])
797fi
798
799# check if libxslt is available
800if test "$enable_xslt" = "yes"; then
801 PKG_CHECK_MODULES([LIBXSLT],[libxslt >= $LIBXSLT_REQUIRED_VERSION])
802 AC_SUBST([LIBXSLT_CFLAGS])
803 AC_SUBST([LIBXSLT_LIBS])
804fi
805
806# check if geoclue is available
807if test "$enable_geolocation" = "yes"; then
808 PKG_CHECK_MODULES([GEOCLUE], [geoclue])
809 AC_SUBST([GEOCLUE_CFLAGS])
810 AC_SUBST([GEOCLUE_LIBS])
811fi
812
813# check if gstreamer is available
814if test "$enable_video" = "yes"; then
815 PKG_CHECK_MODULES([GSTREAMER],
816 [gstreamer-0.10 >= $GSTREAMER_REQUIRED_VERSION
817 gstreamer-app-0.10
818 gstreamer-base-0.10
819 gstreamer-pbutils-0.10
820 gstreamer-plugins-base-0.10 >= $GSTREAMER_PLUGINS_BASE_REQUIRED_VERSION
821 gstreamer-video-0.10])
822 AC_SUBST([GSTREAMER_CFLAGS])
823 AC_SUBST([GSTREAMER_LIBS])
824fi
825
826# check for code coverage support
827if test "$enable_coverage" = "yes"; then
828 COVERAGE_CFLAGS="-MD"
829 COVERAGE_LDFLAGS="-ftest-coverage -fprofile-arcs"
830 AC_SUBST([COVERAGE_CFLAGS])
831 AC_SUBST([COVERAGE_LDFLAGS])
832fi
833
834# check for HTML features
835if test "$enable_video" = "yes"; then
836 html_flags=yes
837fi
838
839GTK_DOC_CHECK([1.10])
840
841# OS conditionals
842AM_CONDITIONAL([OS_WIN32],[test "$os_win32" = "yes"])
843AM_CONDITIONAL([OS_UNIX],[test "$os_win32" = "no"])
844AM_CONDITIONAL([OS_LINUX],[test "$os_linux" = "yes"])
845AM_CONDITIONAL([OS_GNU],[test "$os_gnu" = "yes"])
846AM_CONDITIONAL([OS_FREEBSD],[test "$os_freebsd" = "yes"])
847
848# target conditionals
849AM_CONDITIONAL([TARGET_X11], [test "$with_target" = "x11"])
850AM_CONDITIONAL([TARGET_WIN32], [test "$with_target" = "win32"])
851AM_CONDITIONAL([TARGET_QUARTZ], [test "$with_target" = "quartz"])
852AM_CONDITIONAL([TARGET_DIRECTFB], [test "$with_target" = "directfb"])
853
854# Unicode backend conditionals
855AM_CONDITIONAL([USE_ICU_UNICODE], [test "$with_unicode_backend" = "icu"])
856AM_CONDITIONAL([USE_GLIB_UNICODE], [test "$with_unicode_backend" = "glib"])
857
858# Font backend conditionals
859AM_CONDITIONAL([USE_FREETYPE], [test "$with_font_backend" = "freetype"])
860AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
861
862# WebKit feature conditionals
863AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
864AM_CONDITIONAL([ENABLE_3D_TRANSFORMS],[test "$enable_3D_transforms" = "yes"])
865AM_CONDITIONAL([ENABLE_BLOB_SLICE],[test "$enable_blob_slice" = "yes"])
866AM_CONDITIONAL([ENABLE_CHANNEL_MESSAGING],[test "$enable_channel_messaging" = "yes"])
867AM_CONDITIONAL([ENABLE_JAVASCRIPT_DEBUGGER],[test "$enable_javascript_debugger" = "yes"])
868AM_CONDITIONAL([ENABLE_OFFLINE_WEB_APPLICATIONS],[test "$enable_offline_web_applications" = "yes"])
869AM_CONDITIONAL([ENABLE_DOM_STORAGE],[test "$enable_dom_storage" = "yes"])
870AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
871AM_CONDITIONAL([ENABLE_DATALIST],[test "$enable_datalist" = "yes"])
872AM_CONDITIONAL([ENABLE_EVENTSOURCE],[test "$enable_eventsource" = "yes"])
873AM_CONDITIONAL([ENABLE_FAST_MOBILE_SCROLLING],[test "$enable_fast_mobile_scrolling" = "yes"])
874AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
875AM_CONDITIONAL([ENABLE_IMAGE_RESIZER],[test "$enable_image_resizer" = "yes"])
876AM_CONDITIONAL([ENABLE_INDEXED_DATABASE],[test "$enable_indexed_database" = "yes"])
877AM_CONDITIONAL([ENABLE_INPUT_SPEECH],[test "$enable_input_speech" = "yes"])
878AM_CONDITIONAL([ENABLE_XHTMLMP],[test "$enable_xhtmlmp" = "yes"])
879AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
880AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"])
881AM_CONDITIONAL([ENABLE_FILTERS],[test "$enable_filters" = "yes"])
882AM_CONDITIONAL([ENABLE_FILE_READER],[test "$enable_file_reader" = "yes"])
883AM_CONDITIONAL([ENABLE_FILE_WRITER],[test "$enable_file_writer" = "yes"])
884AM_CONDITIONAL([ENABLE_GEOLOCATION], [test "$enable_geolocation" = "yes"])
885AM_CONDITIONAL([ENABLE_MATHML], [test "$enable_mathml" = "yes"])
886AM_CONDITIONAL([ENABLE_RUBY],[test "$enable_ruby" = "yes"])
887AM_CONDITIONAL([ENABLE_SANDBOX],[test "$enable_sandbox" = "yes"])
888AM_CONDITIONAL([ENABLE_VIDEO],[test "$enable_video" = "yes"])
889AM_CONDITIONAL([ENABLE_NOTIFICATIONS],[test "$enable_notifications" = "yes"])
890AM_CONDITIONAL([ENABLE_ORIENTATION_EVENTS],[test "$enable_orientation_events" = "yes"])
891AM_CONDITIONAL([ENABLE_SVG],[test "$enable_svg" = "yes"])
892AM_CONDITIONAL([ENABLE_SVG_ANIMATION],[test "$enable_svg_animation" = "yes"])
893AM_CONDITIONAL([ENABLE_SVG_FONTS],[test "$enable_svg_fonts" = "yes"])
894AM_CONDITIONAL([ENABLE_SVG_FOREIGN_OBJECT],[test "$enable_svg_foreign_object" = "yes"])
895AM_CONDITIONAL([ENABLE_SVG_AS_IMAGE],[test "$enable_svg_as_image" = "yes"])
896AM_CONDITIONAL([ENABLE_SVG_USE],[test "$enable_svg_use" = "yes"])
897AM_CONDITIONAL([ENABLE_COVERAGE],[test "$enable_coverage" = "yes"])
898AM_CONDITIONAL([ENABLE_FAST_MALLOC],[test "$enable_fast_malloc" = "yes"])
899AM_CONDITIONAL([ENABLE_WML],[test "$enable_wml" = "yes"])
900AM_CONDITIONAL([ENABLE_WORKERS],[test "$enable_workers" = "yes"])
901AM_CONDITIONAL([ENABLE_SHARED_WORKERS],[test "$enable_shared_workers" = "yes"])
902AM_CONDITIONAL([SVG_FLAGS],[test "$svg_flags" = "yes"])
903AM_CONDITIONAL([HTML_FLAGS],[test "$html_flags" = "yes"])
904AM_CONDITIONAL([ENABLE_WEB_SOCKETS],[test "$enable_web_sockets" = "yes"])
905AM_CONDITIONAL([ENABLE_WEB_TIMING],[test "$enable_web_timing" = "yes"])
906
907# Gtk conditionals
908AM_CONDITIONAL([ENABLE_INTROSPECTION],[test "$enable_introspection" = "yes"])
909
910
911AC_CONFIG_FILES([
912GNUmakefile
913WebKit/gtk/webkit/webkitversion.h
914WebKit/gtk/docs/GNUmakefile
915WebKit/gtk/docs/version.xml
916]
917)
918
919AC_CONFIG_FILES([
920WebKit/gtk/${WEBKITGTK_PC_NAME}-${WEBKITGTK_API_VERSION}.pc:WebKit/gtk/webkit.pc.in
921WebKit/gtk/JSCore-${WEBKITGTK_API_VERSION}.gir:WebKit/gtk/JSCore.gir.in]
922,[WEBKITGTK_API_VERSION=$WEBKITGTK_API_VERSION,WEBKITGTK_PC_NAME=$WEBKITGTK_PC_NAME]
923)
924
925AC_OUTPUT
926
927echo "
928WebKit was configured with the following options:
929
930Build configuration:
931 Enable debugging (slow) : $enable_debug
932 Enable GCC build optimization : $enable_optimizations
933 Code coverage support : $enable_coverage
934 Unicode backend : $with_unicode_backend
935 Font backend : $with_font_backend
936 Optimized memory allocator : $enable_fast_malloc
937Features:
938 3D Transforms : $enable_3D_transforms
939 Blob.slice support : $enable_blob_slice
940 Fast Mobile Scrolling : $enable_fast_mobile_scrolling
941 JIT compilation : $enable_jit
942 Filters support : $enable_filters
943 FileReader support : $enable_file_reader
944 FileWriter support : $enable_file_writer
945 Geolocation support : $enable_geolocation
946 JavaScript debugger/profiler support : $enable_javascript_debugger
947 MathML support : $enable_mathml
948 HTML5 offline web applications support : $enable_offline_web_applications
949 HTML5 channel messaging support : $enable_channel_messaging
950 HTML5 client-side session and persistent storage support : $enable_dom_storage
951 HTML5 client-side database storage support : $enable_database
952 HTML5 ruby support : $enable_ruby
953 HTML5 sandboxed iframe support : $enable_sandbox
954 HTML5 server-sent events support : $enable_eventsource
955 HTML5 video element support : $enable_video
956 Icon database support : $enable_icon_database
957 Image resizer support : $enable_image_resizer
958 SharedWorkers support : $enable_shared_workers
959 Speech input support : $enable_input_speech
960 SVG support : $enable_svg
961 SVG animation support : $enable_svg_animation
962 SVG fonts support : $enable_svg_fonts
963 SVG foreign object support : $enable_svg_foreign_object
964 SVG as image support : $enable_svg_as_image
965 SVG use element support : $enable_svg_use
966 WML support : $enable_wml
967 Web Sockets support : $enable_web_sockets
968 Web Timing support : $enable_web_timing
969 Web Workers support : $enable_workers
970 XHTML-MP support : $enable_xhtmlmp
971 XPATH support : $enable_xpath
972 XSLT support : $enable_xslt
973GTK+ configuration:
974 GTK+ version : $with_gtk
975 GDK target : $with_target
976 Hildon UI extensions : $with_hildon
977 Introspection support : $enable_introspection
978"
979if test "$with_unicode_backend" = "glib"; then
980 echo " >> WARNING: the glib-based unicode backend is slow and incomplete <<"
981 echo
982 echo
983fi