summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/web/web_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/web/web_git.bb')
-rw-r--r--meta/recipes-sato/web/web_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-sato/web/web_git.bb b/meta/recipes-sato/web/web_git.bb
new file mode 100644
index 0000000000..612a02daba
--- /dev/null
+++ b/meta/recipes-sato/web/web_git.bb
@@ -0,0 +1,27 @@
1LICENSE = "GPLv2"
2SECTION = "x11"
3DEPENDS = "libxml2 glib-2.0 gtk+ libglade gtkhtml2 curl gconf js libowl"
4DESCRIPTION = "Web is a multi-platform web browsing application."
5PR = "r0"
6
7SRCREV = "96da839f65e17ecc6d5261c1d74accd88423dd7a"
8PV = "0.0+git${SRCPV}"
9
10SRC_URI = "git://git.yoctoproject.org/web-sato;protocol=git \
11 file://owl-window-menu.patch \
12 "
13
14LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
15
16S = "${WORKDIR}/git"
17
18do_unpack_append () {
19 bb.build.exec_func('do_remove_patches', d)
20}
21
22do_remove_patches () {
23 rm -rf ${S}/patches
24}
25
26inherit autotools pkgconfig gconf
27