summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/web/web-webkit_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/web/web-webkit_svn.bb')
-rw-r--r--meta/recipes-sato/web/web-webkit_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-sato/web/web-webkit_svn.bb b/meta/recipes-sato/web/web-webkit_svn.bb
new file mode 100644
index 0000000000..9cdf1f9da3
--- /dev/null
+++ b/meta/recipes-sato/web/web-webkit_svn.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Multi-platform web browsing application."
2HOMEPAGE = "http://o-hand.com/"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "GPLv2"
6
7SECTION = "x11"
8DEPENDS = "libxml2 glib-2.0 gtk+ libglade webkit-gtk curl gconf js libowl"
9
10PV = "0.0+svnr${SRCREV}"
11PR = "r2"
12
13SRC_URI = "svn://svn.o-hand.com/repos/web/branches;module=webkit;proto=http \
14 file://link-with-g++.patch;patch=1"
15
16S = "${WORKDIR}/webkit"
17
18EXTRA_OECONF = "--enable-libowl"
19
20inherit autotools pkgconfig gconf
21
22do_configure_prepend() {
23 touch ${S}/src/dummy.cpp
24}
25
26FILES_${PN} += "${datadir}/web2"