summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/web/web-webkit_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/web/web-webkit_git.bb')
-rw-r--r--meta/recipes-sato/web/web-webkit_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-sato/web/web-webkit_git.bb b/meta/recipes-sato/web/web-webkit_git.bb
new file mode 100644
index 0000000000..2af12bc392
--- /dev/null
+++ b/meta/recipes-sato/web/web-webkit_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Multi-platform web browsing application."
2HOMEPAGE = "http://o-hand.com/"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
7
8SECTION = "x11"
9DEPENDS = "libxml2 glib-2.0 gtk+ libglade webkit-gtk curl gconf js libowl"
10
11# To access https web pages
12RRECOMMENDS_${PN} += "glib-networking"
13
14SRCREV = "0f7019acd9db5383c732d0524c7c3a5eaec9be2b"
15PV = "0.1+git${SRCPV}"
16PR = "r0"
17
18SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
19 file://link-with-g++.patch \
20 file://make-382.patch"
21
22S = "${WORKDIR}/git"
23
24EXTRA_OECONF = "--enable-libowl"
25
26inherit autotools pkgconfig gconf
27
28do_configure_prepend() {
29 touch ${S}/src/dummy.cpp
30}
31
32FILES_${PN} += "${datadir}/web2"