summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/tasks/task-core-x11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/tasks/task-core-x11.bb')
-rw-r--r--meta/recipes-sato/tasks/task-core-x11.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-sato/tasks/task-core-x11.bb b/meta/recipes-sato/tasks/task-core-x11.bb
new file mode 100644
index 0000000000..26d550add2
--- /dev/null
+++ b/meta/recipes-sato/tasks/task-core-x11.bb
@@ -0,0 +1,62 @@
1#
2# Copyright (C) 2011 Intel Corporation
3#
4
5DESCRIPTION = "Tasks for core X11 applications"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9PR = "r35"
10
11PACKAGES = "\
12 task-core-apps-x11-core \
13 task-core-apps-x11-core-dbg \
14 task-core-apps-x11-core-dev \
15 task-core-apps-x11-games \
16 task-core-apps-x11-games-dbg \
17 task-core-apps-x11-games-dev \
18 task-core-x11-base \
19 task-core-x11-base-dbg \
20 task-core-x11-base-dev \
21 "
22
23PACKAGE_ARCH = "${MACHINE_ARCH}"
24
25XSERVER ?= "xserver-kdrive-fbdev"
26
27ALLOW_EMPTY = "1"
28
29# pcmanfm doesn't work on mips/powerpc
30FILEMANAGER ?= "pcmanfm"
31FILEMANAGER_mips ?= ""
32
33
34RDEPENDS_task-core-x11-base = "\
35 dbus \
36 pointercal \
37 matchbox-wm \
38 matchbox-keyboard \
39 matchbox-keyboard-applet \
40 matchbox-keyboard-im \
41 matchbox-panel-2 \
42 matchbox-desktop \
43 matchbox-session \
44 ${XSERVER} \
45 x11-common \
46 xserver-nodm-init \
47 liberation-fonts \
48 xauth \
49 xhost \
50 xset \
51 xrandr"
52
53
54RDEPENDS_task-core-apps-x11-core = "\
55 leafpad \
56 ${FILEMANAGER} \
57 matchbox-terminal \
58 screenshot"
59
60
61RDEPENDS_task-core-apps-x11-games = "\
62 oh-puzzles"