summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/tasks/task-core-x11-mini.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/tasks/task-core-x11-mini.bb')
-rw-r--r--meta/recipes-sato/tasks/task-core-x11-mini.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-sato/tasks/task-core-x11-mini.bb b/meta/recipes-sato/tasks/task-core-x11-mini.bb
new file mode 100644
index 0000000000..98189fe315
--- /dev/null
+++ b/meta/recipes-sato/tasks/task-core-x11-mini.bb
@@ -0,0 +1,45 @@
1#
2# Copyright (C) 2011 Intel Corporation
3#
4
5DESCRIPTION = "Tasks for core X11 applications"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9PR = "r0"
10
11PACKAGES = "\
12 task-core-x11-mini \
13 task-core-x11-mini-dbg \
14 task-core-x11-mini-dev \
15 "
16
17PACKAGE_ARCH = "${MACHINE_ARCH}"
18
19XSERVER ?= "xserver-kdrive-fbdev"
20
21ALLOW_EMPTY = "1"
22
23ROOTLESS_X = "1"
24
25# xserver-common, x11-common
26VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
27
28# elsa, xserver-nodm-init
29VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
30
31
32RDEPENDS_task-core-x11-mini = "\
33 dbus \
34 pointercal \
35 matchbox-terminal \
36 matchbox-wm \
37 mini-x-session \
38 ${XSERVER} \
39 ${VIRTUAL-RUNTIME_xserver_common} \
40 ${VIRTUAL-RUNTIME_graphical_init_manager} \
41 liberation-fonts \
42 xauth \
43 xhost \
44 xset \
45 xrandr"