summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb')
-rw-r--r--meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
new file mode 100644
index 0000000000..d0f507e673
--- /dev/null
+++ b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Provides an icon to shut down the system cleanly"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6SRC_URI = "file://shutdown.desktop"
7
8S = "${WORKDIR}"
9
10do_install() {
11 install -d ${D}${datadir}/applications
12 install -m 0644 shutdown.desktop ${D}${datadir}/applications/
13}
14
15pkg_postinst_${PN} () {
16 grep -q qemuarm $D${sysconfdir}/hostname && \
17 sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/'
18}
19
20inherit allarch