summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.17.bb')
-rw-r--r--meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.17.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.17.bb b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.17.bb
new file mode 100644
index 0000000000..806e3546f6
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.17.bb
@@ -0,0 +1,64 @@
1SECTION = "x11/utils"
2DESCRIPTION = "rxvt-unicode is a clone of the well known \
3terminal emulator rxvt, modified to store text in Unicode \
4(either UCS-2 or UCS-4) and to use locale-correct input and \
5output. It also supports mixing multiple fonts at the \
6same time, including Xft fonts."
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
9 file://src/main.C;beginline=1;endline=31;md5=775485398a09fa7aee6f90464af88432"
10
11DEPENDS = "virtual/libx11 libxt libxft gdk-pixbuf"
12
13PR = "r0"
14
15SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
16 file://xwc.patch \
17 file://rxvt.desktop \
18 file://rxvt.png"
19
20SRC_URI[md5sum] = "1270432bdc7ce17dbb07d41a607081e0"
21SRC_URI[sha256sum] = "de017b2b2a1a7182aeada99f605da33cbee18d450e07a7fdabef48da446521e4"
22
23inherit autotools update-alternatives
24
25PROVIDES = "virtual/x-terminal-emulator"
26ALTERNATIVE_${PN} = "x-terminal-emulator"
27ALTERNATIVE_TARGET[x-terminal-emulator] = "${bindir}/rxvt"
28
29CFLAGS_append = " -fpermissive"
30
31EXTRA_OECONF = "--enable-menubar --enable-xim \
32 --enable-utmp --enable-wtmp --enable-lastlog \
33 --disable-strings --with-term=rxvt --enable-keepscrolling \
34 --enable-xft --with-name=rxvt --enable-frills \
35 --enable-swapscreen --enable-transparency \
36 --with-codesets=eu \
37 --enable-cursor-blink --enable-pointer-blank \
38 --enable-text-blink --enable-rxvt-scroll \
39 --enable-combining --enable-shared \
40 --enable-xgetdefault \
41 --disable-perl \
42 --with-x=${STAGING_DIR_HOST}${prefix}"
43
44do_configure_prepend () {
45 cp aclocal.m4 acinclude.m4
46}
47
48do_compile_prepend () {
49 echo '#define UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
50 echo '#define WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
51 echo '#define LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
52 echo '#define HAVE_XLOCALE 1' >> config.h
53}
54
55do_install_append () {
56 install -d ${D}/${datadir}
57 install -d ${D}/${datadir}/applications
58 install -d ${D}/${datadir}/pixmaps/
59
60 install -m 0644 ${WORKDIR}/rxvt.png ${D}/${datadir}/pixmaps
61 install -m 0644 ${WORKDIR}/rxvt.desktop ${D}/${datadir}/applications
62}
63
64FILES_${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png"