summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.12.bb')
-rw-r--r--meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.12.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.12.bb b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.12.bb
new file mode 100644
index 0000000000..5625245138
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.12.bb
@@ -0,0 +1,67 @@
1SECTION = "x11/utils"
2DEPENDS = "virtual/libx11 libxt libxft"
3DESCRIPTION = "rxvt-unicode is a clone of the well known \
4terminal emulator rxvt, modified to store text in Unicode \
5(either UCS-2 or UCS-4) and to use locale-correct input and \
6output. It also supports mixing multiple fonts at the \
7same time, including Xft fonts."
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
10 file://src/main.C;beginline=1;endline=31;md5=775485398a09fa7aee6f90464af88432"
11
12PR = "r0"
13
14SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
15 file://xwc.patch \
16 file://rxvt.desktop \
17 file://rxvt.png"
18
19SRC_URI[md5sum] = "945af37d661c8c45a7cac292160e7c70"
20SRC_URI[sha256sum] = "1db334204bfb264b3134e01d9d3cf446c5ac7d47514909435f914f3906f37e7e"
21
22inherit autotools update-alternatives
23
24PROVIDES = "virtual/x-terminal-emulator"
25ALTERNATIVE_NAME = "x-terminal-emulator"
26ALTERNATIVE_PATH = "${bindir}/rxvt"
27
28CFLAGS_append = " -fpermissive"
29
30# This is necessary so that the "tic" command executed during the install can
31# link with the correct libary in staging.
32export LD_LIBRARY_PATH = "${STAGING_LIBDIR_NATIVE}"
33
34EXTRA_OECONF = "--enable-menubar --enable-xim \
35 --enable-utmp --enable-wtmp --enable-lastlog \
36 --disable-strings --with-term=rxvt --enable-keepscrolling \
37 --enable-xft --with-name=rxvt --enable-frills \
38 --enable-swapscreen --enable-transparency \
39 --with-codesets=eu \
40 --enable-cursor-blink --enable-pointer-blank \
41 --enable-text-blink --enable-rxvt-scroll \
42 --enable-combining --enable-shared \
43 --enable-xgetdefault \
44 --disable-perl \
45 --with-x=${STAGING_DIR_HOST}${prefix}"
46
47do_configure_prepend () {
48 cp aclocal.m4 acinclude.m4
49}
50
51do_compile_prepend () {
52 echo '#define UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
53 echo '#define WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
54 echo '#define LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
55 echo '#define HAVE_XLOCALE 1' >> config.h
56}
57
58do_install_append () {
59 install -d ${D}/${datadir}
60 install -d ${D}/${datadir}/applications
61 install -d ${D}/${datadir}/pixmaps/
62
63 install -m 0644 ${WORKDIR}/rxvt.png ${D}/${datadir}/pixmaps
64 install -m 0644 ${WORKDIR}/rxvt.desktop ${D}/${datadir}/applications
65}
66
67FILES_${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png"