summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.10.bb')
-rw-r--r--meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.10.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.10.bb b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.10.bb
new file mode 100644
index 0000000000..9657e218b2
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.10.bb
@@ -0,0 +1,65 @@
1SECTION = "x11/utils"
2DEPENDS = "virtual/libx11 libxt libxft"
3DESCRIPTION = "rxvt-unicode is a clone of the well known \
4terminal emulator rxvt, modified to store text in Unicode \
5(either UCS-2 or UCS-4) and to use locale-correct input and \
6output. It also supports mixing multiple fonts at the \
7same time, including Xft fonts."
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
10 file://src/main.C;beginline=1;endline=31;md5=633e23cdeb89fe980ded9a3af4f335c2"
11SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
12 file://xwc.patch \
13 file://rxvt.desktop \
14 file://rxvt.png"
15PR = "r0"
16
17inherit autotools update-alternatives
18
19PROVIDES = "virtual/x-terminal-emulator"
20ALTERNATIVE_NAME = "x-terminal-emulator"
21ALTERNATIVE_PATH = "${bindir}/rxvt"
22
23CFLAGS_append = " -fpermissive"
24
25# This is necessary so that the "tic" command executed during the install can
26# link with the correct libary in staging.
27export LD_LIBRARY_PATH = "${STAGING_LIBDIR_NATIVE}"
28
29EXTRA_OECONF = "--enable-menubar --enable-xim \
30 --enable-utmp --enable-wtmp --enable-lastlog \
31 --disable-strings --with-term=rxvt --enable-keepscrolling \
32 --enable-xft --with-name=rxvt --enable-frills \
33 --enable-swapscreen --enable-transparency \
34 --with-codesets=eu \
35 --enable-cursor-blink --enable-pointer-blank \
36 --enable-text-blink --enable-rxvt-scroll \
37 --enable-combining --enable-shared \
38 --enable-xgetdefault \
39 --disable-perl \
40 --with-x=${STAGING_DIR_HOST}${prefix}"
41
42do_configure_prepend () {
43 cp aclocal.m4 acinclude.m4
44}
45
46do_compile_prepend () {
47 echo '#define UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
48 echo '#define WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
49 echo '#define LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
50 echo '#define HAVE_XLOCALE 1' >> config.h
51}
52
53do_install_append () {
54 install -d ${D}/${datadir}
55 install -d ${D}/${datadir}/applications
56 install -d ${D}/${datadir}/pixmaps/
57
58 install -m 0644 ${WORKDIR}/rxvt.png ${D}/${datadir}/pixmaps
59 install -m 0644 ${WORKDIR}/rxvt.desktop ${D}/${datadir}/applications
60}
61
62FILES_${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png"
63
64SRC_URI[md5sum] = "a23aa40b31e843878b6f9c44768de430"
65SRC_URI[sha256sum] = "1c238f7e545b1a8da81239b826fb2a7d196c73effbcbd211db7a50995a0a067a"