summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/rxvt-unicode/rxvt-unicode_5.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/rxvt-unicode/rxvt-unicode_5.6.bb')
-rw-r--r--meta/recipes-sato/rxvt-unicode/rxvt-unicode_5.6.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-sato/rxvt-unicode/rxvt-unicode_5.6.bb b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_5.6.bb
new file mode 100644
index 0000000000..d13089501f
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_5.6.bb
@@ -0,0 +1,72 @@
1SECTION = "x11/utils"
2DEPENDS = "virtual/libx11 libxt libxft"
3DESCRIPTION = "rxvt-unicode is a clone of the well known \
4terminal emulator rxvt, modified to store text in Unicode \
5(either UCS-2 or UCS-4) and to use locale-correct input and \
6output. It also supports mixing multiple fonts at the \
7same time, including Xft fonts."
8LICENSE = "GPL"
9SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
10 file://xwc.patch;patch=1 \
11 file://signedchar.patch;patch=1 \
12 file://rxvt.desktop \
13 file://rxvt.png"
14PR = "r5"
15
16inherit autotools update-alternatives
17
18PROVIDES = "virtual/x-terminal-emulator"
19ALTERNATIVE_NAME = "x-terminal-emulator"
20ALTERNATIVE_PATH = "${bindir}/rxvt"
21
22CFLAGS_append = " -fpermissive"
23
24# This is necessary so that the "tic" command executed during the install can
25# link with the correct libary in staging.
26export LD_LIBRARY_PATH = "${STAGING_LIBDIR_NATIVE}"
27
28EXTRA_OECONF = "--enable-menubar --enable-xim \
29 --enable-utmp --enable-wtmp --enable-lastlog \
30 --disable-strings --with-term=rxvt --enable-keepscrolling \
31 --enable-xft --with-name=rxvt --enable-frills \
32 --enable-swapscreen --enable-transparency \
33 --with-codesets=eu \
34 --enable-cursor-blink --enable-pointer-blank \
35 --enable-text-blink --enable-rxvt-scroll \
36 --enable-combining --enable-shared \
37 --enable-xgetdefault \
38 --with-x=${STAGING_DIR_HOST}${prefix}"
39EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
40 'XLIB=-L${STAGING_LIBDIR} -lX11'"
41
42do_configure () {
43 mv autoconf/configure.in . || true
44 rm autoconf/libtool.m4
45 libtoolize --force
46 autotools_do_configure
47 echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
48 echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
49 echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
50 echo '#define HAVE_XLOCALE 1' >> config.h
51}
52
53do_compile () {
54 if test -e ${S}/${HOST_SYS}-libtool; then
55 LIBTOOL=${S}/${HOST_SYS}-libtool
56 else
57 LIBTOOL=${S}/libtool
58 fi
59 # docs need "yodl" and I have no idea what that is
60 oe_runmake -C src "LIBTOOL=$LIBTOOL"
61}
62
63do_install_append () {
64 install -d ${D}/${datadir}
65 install -d ${D}/${datadir}/applications
66 install -d ${D}/${datadir}/pixmaps/
67
68 install -m 0644 ${WORKDIR}/rxvt.png ${D}/${datadir}/pixmaps
69 install -m 0644 ${WORKDIR}/rxvt.desktop ${D}/${datadir}/applications
70}
71
72FILES_${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png"