diff options
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r9561.bb')
-rw-r--r-- | meta/recipes-sato/puzzles/puzzles_r9561.bb | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9561.bb b/meta/recipes-sato/puzzles/puzzles_r9561.bb new file mode 100644 index 0000000000..83fabdf217 --- /dev/null +++ b/meta/recipes-sato/puzzles/puzzles_r9561.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | DESCRIPTION="Simon Tatham's Portable Puzzle Collection" | ||
2 | HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/" | ||
3 | |||
4 | DEPENDS = "gtk+ libxt" | ||
5 | PR = "r0" | ||
6 | MOD_PV = "${@d.getVar('PV',1)[1:]}" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=453de74d749439762ef4814f7bee1fec" | ||
10 | |||
11 | # Upstream updates puzzles.tar.gz for the new release, so checksums seem to be changing regularly right now | ||
12 | #SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV}" | ||
13 | SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz" | ||
14 | SRC_URI[md5sum] = "c86695aebfc95efe1d6241863849101b" | ||
15 | SRC_URI[sha256sum] = "2c20a45189387e3de8804a58bdb4e47ac4bb0f890001a509dfbdc015b5a84b95" | ||
16 | |||
17 | |||
18 | S = "${WORKDIR}/${BPN}-${PV}" | ||
19 | |||
20 | do_configure () { | ||
21 | ./mkfiles.pl | ||
22 | } | ||
23 | |||
24 | do_compile_prepend = " \ | ||
25 | export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \ | ||
26 | export XLFLAGS=-lm \ | ||
27 | export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; " | ||
28 | |||
29 | FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*" | ||
30 | FILES_${PN}-dbg += "${prefix}/games/.debug" | ||
31 | |||
32 | do_install () { | ||
33 | rm -rf ${D}/* | ||
34 | export prefix=${D} | ||
35 | export DESTDIR=${D} | ||
36 | install -d ${D}/${prefix}/ | ||
37 | install -d ${D}/${prefix}/games/ | ||
38 | oe_runmake install | ||
39 | |||
40 | install -d ${D}/${datadir}/ | ||
41 | install -d ${D}/${datadir}/applications/ | ||
42 | |||
43 | cd ${D}/${prefix}/games | ||
44 | for prog in *; do | ||
45 | if [ -x $prog ]; then | ||
46 | # Convert prog to Title Case | ||
47 | title=$(echo $prog | sed 's/\(^\| \)./\U&/g') | ||
48 | echo "making ${D}/${datadir}/applications/$prog.desktop" | ||
49 | cat <<STOP > ${D}/${datadir}/applications/$prog.desktop | ||
50 | [Desktop Entry] | ||
51 | Name=$title | ||
52 | Exec=${prefix}/games/$prog | ||
53 | Icon=applications-games | ||
54 | Terminal=false | ||
55 | Type=Application | ||
56 | Categories=Game; | ||
57 | StartupNotify=true | ||
58 | X-MB-SingleInstance=true | ||
59 | STOP | ||
60 | fi | ||
61 | done | ||
62 | } | ||