diff options
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r9306.bb')
-rw-r--r-- | meta/recipes-sato/puzzles/puzzles_r9306.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9306.bb b/meta/recipes-sato/puzzles/puzzles_r9306.bb new file mode 100644 index 0000000000..ee0c02537a --- /dev/null +++ b/meta/recipes-sato/puzzles/puzzles_r9306.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | DESCRIPTION="Simon Tatham's Portable Puzzle Collection" | ||
2 | HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/" | ||
3 | |||
4 | DEPENDS = "gtk+ libxt" | ||
5 | PR = "r0" | ||
6 | MOD_PV = "${@bb.data.getVar('PV',d,1)[1:]}" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=9928b60f3b78be315b7ab699c1b03ff5" | ||
10 | |||
11 | SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz" | ||
12 | |||
13 | # Upstream updates puzzles.tar.gz for the new release, so checksums seem to be changing regularly right now | ||
14 | #SRC_URI[md5sum] = "e8b4c7e2341264789f3cd6733857bf1c" | ||
15 | #SRC_URI[sha256sum] = "69f37e497e63b2f7ab44e7bbd50aee078269c16dbc2d78ec1b00257678f2cbd2" | ||
16 | #SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV}" | ||
17 | |||
18 | S = "${WORKDIR}/${BPN}-${PV}" | ||
19 | |||
20 | do_configure () { | ||
21 | ./mkfiles.pl | ||
22 | } | ||
23 | |||
24 | do_compile_prepend = " \ | ||
25 | export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \ | ||
26 | export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; " | ||
27 | |||
28 | FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*" | ||
29 | FILES_${PN}-dbg += "${prefix}/games/.debug" | ||
30 | |||
31 | do_install () { | ||
32 | rm -rf ${D}/* | ||
33 | export prefix=${D} | ||
34 | export DESTDIR=${D} | ||
35 | install -d ${D}/${prefix}/ | ||
36 | install -d ${D}/${prefix}/games/ | ||
37 | oe_runmake install | ||
38 | |||
39 | install -d ${D}/${datadir}/ | ||
40 | install -d ${D}/${datadir}/applications/ | ||
41 | |||
42 | cd ${D}/${prefix}/games | ||
43 | for prog in *; do | ||
44 | if [ -x $prog ]; then | ||
45 | # Convert prog to Title Case | ||
46 | title=$(echo $prog | sed 's/\(^\| \)./\U&/g') | ||
47 | echo "making ${D}/${datadir}/applications/$prog.desktop" | ||
48 | cat <<STOP > ${D}/${datadir}/applications/$prog.desktop | ||
49 | [Desktop Entry] | ||
50 | Name=$title | ||
51 | Exec=${prefix}/games/$prog | ||
52 | Icon=applications-games | ||
53 | Terminal=false | ||
54 | Type=Application | ||
55 | Categories=Game; | ||
56 | StartupNotify=true | ||
57 | X-MB-SingleInstance=true | ||
58 | STOP | ||
59 | fi | ||
60 | done | ||
61 | } | ||