diff options
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r9076.bb')
-rw-r--r-- | meta/recipes-sato/puzzles/puzzles_r9076.bb | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9076.bb b/meta/recipes-sato/puzzles/puzzles_r9076.bb new file mode 100644 index 0000000000..97582e264c --- /dev/null +++ b/meta/recipes-sato/puzzles/puzzles_r9076.bb | |||
@@ -0,0 +1,60 @@ | |||
1 | DESCRIPTION="Simon Tatham's Portable Puzzle Collection" | ||
2 | HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/" | ||
3 | |||
4 | DEPENDS = "gtk+ libxt" | ||
5 | PR = "r0" | ||
6 | MOD_PV = "${@bb.data.getVar('PV',d,1)[1:]}" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=9928b60f3b78be315b7ab699c1b03ff5" | ||
10 | |||
11 | SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz" | ||
12 | |||
13 | SRC_URI[md5sum] = "69a3b81f5fe815f4e6fbb089af9c04f3" | ||
14 | SRC_URI[sha256sum] = "26343db44dd656cc182e20c78dae0c013bb2f43f6c79c327510ea629a8eb7bbc" | ||
15 | #SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV}" | ||
16 | |||
17 | S = "${WORKDIR}/${PN}-${PV}" | ||
18 | |||
19 | do_configure () { | ||
20 | ./mkfiles.pl | ||
21 | } | ||
22 | |||
23 | do_compile_prepend = " \ | ||
24 | export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \ | ||
25 | export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; " | ||
26 | |||
27 | FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*" | ||
28 | FILES_${PN}-dbg += "${prefix}/games/.debug" | ||
29 | |||
30 | do_install () { | ||
31 | rm -rf ${D}/* | ||
32 | export prefix=${D} | ||
33 | export DESTDIR=${D} | ||
34 | install -d ${D}/${prefix}/ | ||
35 | install -d ${D}/${prefix}/games/ | ||
36 | oe_runmake install | ||
37 | |||
38 | install -d ${D}/${datadir}/ | ||
39 | install -d ${D}/${datadir}/applications/ | ||
40 | |||
41 | cd ${D}/${prefix}/games | ||
42 | for prog in *; do | ||
43 | if [ -x $prog ]; then | ||
44 | # Convert prog to Title Case | ||
45 | title=$(echo $prog | sed 's/\(^\| \)./\U&/g') | ||
46 | echo "making ${D}/${datadir}/applications/$prog.desktop" | ||
47 | cat <<STOP > ${D}/${datadir}/applications/$prog.desktop | ||
48 | [Desktop Entry] | ||
49 | Name=$title | ||
50 | Exec=${prefix}/games/$prog | ||
51 | Icon=applications-games | ||
52 | Terminal=false | ||
53 | Type=Application | ||
54 | Categories=Game; | ||
55 | StartupNotify=true | ||
56 | X-MB-SingleInstance=true | ||
57 | STOP | ||
58 | fi | ||
59 | done | ||
60 | } | ||