summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r9076.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r9076.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r9076.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9076.bb b/meta/recipes-sato/puzzles/puzzles_r9076.bb
new file mode 100644
index 0000000000..97582e264c
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_r9076.bb
@@ -0,0 +1,60 @@
1DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
2HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
3
4DEPENDS = "gtk+ libxt"
5PR = "r0"
6MOD_PV = "${@bb.data.getVar('PV',d,1)[1:]}"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=9928b60f3b78be315b7ab699c1b03ff5"
10
11SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "69a3b81f5fe815f4e6fbb089af9c04f3"
14SRC_URI[sha256sum] = "26343db44dd656cc182e20c78dae0c013bb2f43f6c79c327510ea629a8eb7bbc"
15#SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV}"
16
17S = "${WORKDIR}/${PN}-${PV}"
18
19do_configure () {
20 ./mkfiles.pl
21}
22
23do_compile_prepend = " \
24 export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
25 export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
26
27FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*"
28FILES_${PN}-dbg += "${prefix}/games/.debug"
29
30do_install () {
31 rm -rf ${D}/*
32 export prefix=${D}
33 export DESTDIR=${D}
34 install -d ${D}/${prefix}/
35 install -d ${D}/${prefix}/games/
36 oe_runmake install
37
38 install -d ${D}/${datadir}/
39 install -d ${D}/${datadir}/applications/
40
41 cd ${D}/${prefix}/games
42 for prog in *; do
43 if [ -x $prog ]; then
44 # Convert prog to Title Case
45 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
46 echo "making ${D}/${datadir}/applications/$prog.desktop"
47 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
48[Desktop Entry]
49Name=$title
50Exec=${prefix}/games/$prog
51Icon=applications-games
52Terminal=false
53Type=Application
54Categories=Game;
55StartupNotify=true
56X-MB-SingleInstance=true
57STOP
58 fi
59 done
60}