summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r9023.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r9023.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r9023.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9023.bb b/meta/recipes-sato/puzzles/puzzles_r9023.bb
new file mode 100644
index 0000000000..e51bd7a560
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_r9023.bb
@@ -0,0 +1,57 @@
1DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
2HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
3
4DEPENDS = "gtk+ libxt"
5PR = "r0"
6MOD_PV = "${@bb.data.getVar('PV',d,1)[1:]}"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=9928b60f3b78be315b7ab699c1b03ff5"
10
11SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz"
12#SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV}"
13
14S = "${WORKDIR}/${PN}-${PV}"
15
16do_configure () {
17 ./mkfiles.pl
18}
19
20do_compile_prepend = " \
21 export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
22 export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
23
24FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*"
25FILES_${PN}-dbg += "${prefix}/games/.debug"
26
27do_install () {
28 rm -rf ${D}/*
29 export prefix=${D}
30 export DESTDIR=${D}
31 install -d ${D}/${prefix}/
32 install -d ${D}/${prefix}/games/
33 oe_runmake install
34
35 install -d ${D}/${datadir}/
36 install -d ${D}/${datadir}/applications/
37
38 cd ${D}/${prefix}/games
39 for prog in *; do
40 if [ -x $prog ]; then
41 # Convert prog to Title Case
42 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
43 echo "making ${D}/${datadir}/applications/$prog.desktop"
44 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
45[Desktop Entry]
46Name=$title
47Exec=${prefix}/games/$prog
48Icon=applications-games
49Terminal=false
50Type=Application
51Categories=Game;
52StartupNotify=true
53X-MB-SingleInstance=true
54STOP
55 fi
56 done
57}