summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r7593.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r7593.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r7593.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r7593.bb b/meta/recipes-sato/puzzles/puzzles_r7593.bb
new file mode 100644
index 0000000000..eb1e009353
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_r7593.bb
@@ -0,0 +1,53 @@
1
2DEPENDS = "gtk+ libxt"
3PR = "r8"
4MOD_PV = "${@bb.data.getVar('PV',d,1)[1:]}"
5
6#SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz"
7SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV} \
8 file://makedist_hack.patch;patch=1"
9
10S = "${WORKDIR}/${PN}"
11
12do_configure () {
13 ./makedist.sh ${MOD_PV}
14}
15
16do_compile_prepend = " \
17 export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
18 export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
19
20FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*"
21FILES_${PN}-dbg += "${prefix}/games/.debug"
22
23do_install () {
24 rm -rf ${D}/*
25 export prefix=${D}
26 export DESTDIR=${D}
27 install -d ${D}/${prefix}/
28 install -d ${D}/${prefix}/games/
29 oe_runmake install
30
31 install -d ${D}/${datadir}/
32 install -d ${D}/${datadir}/applications/
33
34 cd ${D}/${prefix}/games
35 for prog in *; do
36 if [ -x $prog ]; then
37 # Convert prog to Title Case
38 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
39 echo "making ${D}/${datadir}/applications/$prog.desktop"
40 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
41[Desktop Entry]
42Name=$title
43Exec=${prefix}/games/$prog
44Icon=applications-games
45Terminal=false
46Type=Application
47Categories=Game;
48StartupNotify=true
49X-MB-SingleInstance=true
50STOP
51 fi
52 done
53}