summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r10116.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r10116.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r10116.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r10116.bb b/meta/recipes-sato/puzzles/puzzles_r10116.bb
new file mode 100644
index 0000000000..842c648be5
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_r10116.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Simon Tatham's Portable Puzzle Collection"
2HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
3
4DEPENDS = "gtk+ libxt"
5MOD_PV = "${@d.getVar('PV',1)[1:]}"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENCE;md5=33bcd4bce8f3c197f2aefbdbd2d299bc"
9
10SRC_URI = "svn://svn.tartarus.org/sgt;module=puzzles;rev=${MOD_PV}"
11
12S = "${WORKDIR}/${BPN}"
13
14inherit autotools
15
16do_configure_prepend () {
17 ./mkfiles.pl
18}
19
20FILES_${PN} = "${prefix}/bin/* ${datadir}/applications/*"
21FILES_${PN}-dbg += "${prefix}/bin/.debug"
22
23do_install () {
24 rm -rf ${D}/*
25 export prefix=${D}
26 export DESTDIR=${D}
27 install -d ${D}/${prefix}/bin/
28 oe_runmake install
29
30
31 install -d ${D}/${datadir}/applications/
32
33 # Create desktop shortcuts
34 cd ${D}/${prefix}/bin
35 for prog in *; do
36 if [ -x $prog ]; then
37 # Convert prog to Title Case
38 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
39 echo "making ${D}/${datadir}/applications/$prog.desktop"
40 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
41[Desktop Entry]
42Name=$title
43Exec=${prefix}/bin/$prog
44Icon=applications-games
45Terminal=false
46Type=Application
47Categories=Game;
48StartupNotify=true
49X-MB-SingleInstance=true
50STOP
51 fi
52 done
53}