diff options
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r10116.bb')
-rw-r--r-- | meta/recipes-sato/puzzles/puzzles_r10116.bb | 53 |
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r10116.bb b/meta/recipes-sato/puzzles/puzzles_r10116.bb new file mode 100644 index 0000000000..842c648be5 --- /dev/null +++ b/meta/recipes-sato/puzzles/puzzles_r10116.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | SUMMARY = "Simon Tatham's Portable Puzzle Collection" | ||
2 | HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/" | ||
3 | |||
4 | DEPENDS = "gtk+ libxt" | ||
5 | MOD_PV = "${@d.getVar('PV',1)[1:]}" | ||
6 | |||
7 | LICENSE = "MIT" | ||
8 | LIC_FILES_CHKSUM = "file://LICENCE;md5=33bcd4bce8f3c197f2aefbdbd2d299bc" | ||
9 | |||
10 | SRC_URI = "svn://svn.tartarus.org/sgt;module=puzzles;rev=${MOD_PV}" | ||
11 | |||
12 | S = "${WORKDIR}/${BPN}" | ||
13 | |||
14 | inherit autotools | ||
15 | |||
16 | do_configure_prepend () { | ||
17 | ./mkfiles.pl | ||
18 | } | ||
19 | |||
20 | FILES_${PN} = "${prefix}/bin/* ${datadir}/applications/*" | ||
21 | FILES_${PN}-dbg += "${prefix}/bin/.debug" | ||
22 | |||
23 | do_install () { | ||
24 | rm -rf ${D}/* | ||
25 | export prefix=${D} | ||
26 | export DESTDIR=${D} | ||
27 | install -d ${D}/${prefix}/bin/ | ||
28 | oe_runmake install | ||
29 | |||
30 | |||
31 | install -d ${D}/${datadir}/applications/ | ||
32 | |||
33 | # Create desktop shortcuts | ||
34 | cd ${D}/${prefix}/bin | ||
35 | for prog in *; do | ||
36 | if [ -x $prog ]; then | ||
37 | # Convert prog to Title Case | ||
38 | title=$(echo $prog | sed 's/\(^\| \)./\U&/g') | ||
39 | echo "making ${D}/${datadir}/applications/$prog.desktop" | ||
40 | cat <<STOP > ${D}/${datadir}/applications/$prog.desktop | ||
41 | [Desktop Entry] | ||
42 | Name=$title | ||
43 | Exec=${prefix}/bin/$prog | ||
44 | Icon=applications-games | ||
45 | Terminal=false | ||
46 | Type=Application | ||
47 | Categories=Game; | ||
48 | StartupNotify=true | ||
49 | X-MB-SingleInstance=true | ||
50 | STOP | ||
51 | fi | ||
52 | done | ||
53 | } | ||