summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/oh-puzzles_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/puzzles/oh-puzzles_svn.bb')
-rw-r--r--meta/recipes-sato/puzzles/oh-puzzles_svn.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/oh-puzzles_svn.bb b/meta/recipes-sato/puzzles/oh-puzzles_svn.bb
new file mode 100644
index 0000000000..5fcea24b37
--- /dev/null
+++ b/meta/recipes-sato/puzzles/oh-puzzles_svn.bb
@@ -0,0 +1,69 @@
1DESCRIPTION = "Portable Puzzle Collection"
2HOMEPAGE = "http://o-hand.com/"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=f56ec6772dd1c7c367067bbea8ea1675 \
7 file://src/tree234.h;endline=28;md5=a188e6d250430ca094a54a82f48472a7 \
8 file://src/tree234.c;endline=28;md5=b4feb1976feebf8f1379093ed52f2945"
9
10SECTION = "x11"
11DEPENDS = "gtk+ gconf intltool-native librsvg"
12DEPENDS_append_poky = " libowl"
13
14PV = "0.1+svnr${SRCREV}"
15PR = "r10"
16
17bindir = "/usr/games"
18
19inherit autotools pkgconfig
20
21SRC_URI = "svn://svn.o-hand.com/repos/;module=oh-puzzles;proto=http"
22SRC_URI_append_poky = " file://oh-puzzles-owl-menu.patch;patch=1;pnum=0 "
23
24S = "${WORKDIR}/${PN}"
25
26EXTRA_OEMAKE += "GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1"
27
28do_install_append () {
29 install -d ${D}/${datadir}/applications/
30
31 cd ${D}/${prefix}/games
32 for prog in *; do
33 if [ -x $prog ]; then
34 # Convert prog to Title Case
35 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
36 echo "making ${D}/${datadir}/applications/$prog.desktop"
37 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
38[Desktop Entry]
39Name=$title
40Exec=${prefix}/games/$prog
41Icon=applications-games
42Terminal=false
43Type=Application
44Categories=Game;
45StartupNotify=true
46X-MB-SingleInstance=true
47Comment=Play $title.
48STOP
49 fi
50 done
51}
52
53PACKAGES += ${PN}-extra
54RDEPENDS_${PN}-extra += "oh-puzzles"
55
56FILES_${PN} = "/usr/share/pixmaps /usr/share/oh-puzzles/"
57FILES_${PN}-dbg += "/usr/games/.debug/*"
58FILES_${PN}-extra = "/usr/games/ /usr/share/applications /etc/gconf/schemas"
59
60python __anonymous () {
61 import bb
62 var = bb.data.expand("FILES_${PN}", d, 1)
63 data = bb.data.getVar(var, d, 1)
64 for name in ("bridges", "fifteen", "inertia", "map", "samegame", "slant"):
65 data = data + " /usr/games/%s" % name
66 data = data + " /usr/share/applications/%s.desktop" % name
67 data = data + " /etc/gconf/schemas/%s.schemas" % name
68 bb.data.setVar(var, data, d)
69}