summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/oh-puzzles_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/puzzles/oh-puzzles_git.bb')
-rw-r--r--meta/recipes-sato/puzzles/oh-puzzles_git.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/oh-puzzles_git.bb b/meta/recipes-sato/puzzles/oh-puzzles_git.bb
new file mode 100644
index 0000000000..6d95d79e8c
--- /dev/null
+++ b/meta/recipes-sato/puzzles/oh-puzzles_git.bb
@@ -0,0 +1,70 @@
1DESCRIPTION = "Portable Puzzle Collection"
2HOMEPAGE = "http://o-hand.com/"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=f56ec6772dd1c7c367067bbea8ea1675 \
7 file://src/tree234.h;endline=28;md5=a188e6d250430ca094a54a82f48472a7 \
8 file://src/tree234.c;endline=28;md5=b4feb1976feebf8f1379093ed52f2945"
9
10SECTION = "x11"
11DEPENDS = "gtk+ gconf intltool-native librsvg"
12DEPENDS_append_poky = " libowl"
13
14SRCREV = "92f1a20e4b72eed7a35b00984d9793b51dc2fb3b"
15PV = "0.2+git${SRCPV}"
16PR = "r10"
17
18SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git"
19SRC_URI_append_poky = " file://oh-puzzles-owl-menu.patch;striplevel=0 "
20
21S = "${WORKDIR}/git"
22
23inherit autotools pkgconfig
24
25bindir = "/usr/games"
26
27EXTRA_OEMAKE += "GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1"
28
29do_install_append () {
30 install -d ${D}/${datadir}/applications/
31
32 cd ${D}/${prefix}/games
33 for prog in *; do
34 if [ -x $prog ]; then
35 # Convert prog to Title Case
36 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
37 echo "making ${D}/${datadir}/applications/$prog.desktop"
38 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
39[Desktop Entry]
40Name=$title
41Exec=${prefix}/games/$prog
42Icon=applications-games
43Terminal=false
44Type=Application
45Categories=Game;
46StartupNotify=true
47X-MB-SingleInstance=true
48Comment=Play $title.
49STOP
50 fi
51 done
52}
53
54PACKAGES += ${PN}-extra
55RDEPENDS_${PN}-extra += "oh-puzzles"
56
57FILES_${PN} = "/usr/share/pixmaps /usr/share/oh-puzzles/"
58FILES_${PN}-dbg += "/usr/games/.debug/*"
59FILES_${PN}-extra = "/usr/games/ /usr/share/applications /etc/gconf/schemas"
60
61python __anonymous () {
62 import bb
63 var = bb.data.expand("FILES_${PN}", d, 1)
64 data = bb.data.getVar(var, d, 1)
65 for name in ("bridges", "fifteen", "inertia", "map", "samegame", "slant"):
66 data = data + " /usr/games/%s" % name
67 data = data + " /usr/share/applications/%s.desktop" % name
68 data = data + " /etc/gconf/schemas/%s.schemas" % name
69 bb.data.setVar(var, data, d)
70}