summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/pcmanfm/pcmanfm_1.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/pcmanfm/pcmanfm_1.2.5.bb')
-rw-r--r--meta/recipes-sato/pcmanfm/pcmanfm_1.2.5.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-sato/pcmanfm/pcmanfm_1.2.5.bb b/meta/recipes-sato/pcmanfm/pcmanfm_1.2.5.bb
new file mode 100644
index 0000000000..aab79113d9
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/pcmanfm_1.2.5.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Fast lightweight tabbed filemanager"
2HOMEPAGE = "http://pcmanfm.sourceforge.net/"
3
4LICENSE = "GPLv2 & GPLv2+ & LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
6 file://src/pcmanfm.h;endline=22;md5=417b3855771a3a87f8ad753d994491f0 \
7 file://src/gseal-gtk-compat.h;endline=21;md5=46922c8691f58d124f9420fe16149ce2"
8
9SECTION = "x11"
10DEPENDS = "gtk+3 startup-notification libfm intltool-native gettext-native"
11
12
13COMPATIBLE_HOST = '(x86_64.*|i.86.*|aarch64.*|arm.*|mips.*|powerpc.*|sh.*)-(linux|freebsd.*)'
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.xz \
16 file://gnome-fs-directory.png \
17 file://gnome-fs-regular.png \
18 file://gnome-mime-text-plain.png \
19 file://emblem-symbolic-link.png \
20 file://no-desktop.patch"
21
22SRC_URI[md5sum] = "b4d1f8ce08d87e4f27805a246fc51ac2"
23SRC_URI[sha256sum] = "0c86cac028b705ff314c7464d814c2cf7ff604c17491c20aa204b1ef1a80ad67"
24
25UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/pcmanfm/files/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/PCManFM/"
26
27inherit autotools pkgconfig distro_features_check
28
29# The startup-notification requires x11 in DISTRO_FEATURES
30REQUIRED_DISTRO_FEATURES = "x11"
31
32EXTRA_OECONF = "--with-gtk=3"
33
34do_install_append () {
35 install -d ${D}/${datadir}
36 install -d ${D}/${datadir}/pixmaps/
37
38 install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
39}
40
41FILES_${PN} += "${libdir}/pcmanfm"
42
43RRECOMMENDS_${PN} += "adwaita-icon-theme"