summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/pcmanfm/pcmanfm_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/pcmanfm/pcmanfm_1.1.0.bb')
-rw-r--r--meta/recipes-sato/pcmanfm/pcmanfm_1.1.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-sato/pcmanfm/pcmanfm_1.1.0.bb b/meta/recipes-sato/pcmanfm/pcmanfm_1.1.0.bb
new file mode 100644
index 0000000000..bcfc9db08b
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/pcmanfm_1.1.0.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "Fast lightweight tabbed filemanager"
2HOMEPAGE = "http://pcmanfm.sourceforge.net/"
3BUGTRACKER = ""
4
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://src/pcmanfm.h;endline=22;md5=417b3855771a3a87f8ad753d994491f0 \
8 file://src/gseal-gtk-compat.h;endline=21;md5=46922c8691f58d124f9420fe16149ce2"
9
10SECTION = "x11"
11DEPENDS = "gtk+ startup-notification libfm"
12DEPENDS_append_poky = " libowl"
13
14PR = "r0"
15
16COMPATIBLE_HOST = '(x86_64.*|i.86.*|aarch64.*|arm.*|mips.*|powerpc.*|sh.*)-(linux|freebsd.*)'
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.gz \
19 file://gnome-fs-directory.png \
20 file://gnome-fs-regular.png \
21 file://gnome-mime-text-plain.png \
22 file://emblem-symbolic-link.png \
23 file://cross-compile-fix.patch"
24
25SRC_URI[md5sum] = "af0cff78690e658f3c06ceabf27bc71a"
26SRC_URI[sha256sum] = "1f6301f330ad648f3322708ec6c0f680a8695a9453932fe19653bab6731e5582"
27
28inherit autotools pkgconfig
29
30do_install_append () {
31 install -d ${D}/${datadir}
32 install -d ${D}/${datadir}/pixmaps/
33
34 install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
35}