summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb')
-rw-r--r--meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb b/meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb
new file mode 100644
index 0000000000..af283f6cf8
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "Fast lightweight tabbed filemanager"
2HOMEPAGE = "http://pcmanfm.sourceforge.net/"
3BUGTRACKER = ""
4
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://src/pcmanfm.h;endline=22;md5=417b3855771a3a87f8ad753d994491f0 \
8 file://src/gseal-gtk-compat.h;endline=21;md5=46922c8691f58d124f9420fe16149ce2"
9
10SECTION = "x11"
11DEPENDS = "gtk+ startup-notification libfm"
12DEPENDS_append_poky = " libowl"
13
14PR = "r0"
15
16COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|mips.*|powerpc.*)-(linux|freebsd.*)'
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.gz \
19 file://gnome-fs-directory.png \
20 file://gnome-fs-regular.png \
21 file://gnome-mime-text-plain.png \
22 file://emblem-symbolic-link.png \
23 file://cross-compile-fix.patch"
24
25SRC_URI_append_poky = " file://owl-window-menu.patch"
26
27SRC_URI[md5sum] = "f31ed6defb600f7046a456220d8efa3a"
28SRC_URI[sha256sum] = "bc48af4ade638b47e4207cc274f6e38c2bd3786a811d20da47c3df9907c6fb6c"
29
30inherit autotools pkgconfig
31
32do_install_append () {
33 install -d ${D}/${datadir}
34 install -d ${D}/${datadir}/pixmaps/
35
36 install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
37}