summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb')
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb40
1 files changed, 33 insertions, 7 deletions
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
index f38e0d2800..b31eabad11 100644
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
@@ -12,25 +12,51 @@ inherit packagegroup
12 12
13PACKAGE_ARCH = "${MACHINE_ARCH}" 13PACKAGE_ARCH = "${MACHINE_ARCH}"
14 14
15PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
16
17RDEPENDS_${PN} = "\
18 ${PN}-base \
19 ${PN}-apps \
20 ${PN}-games \
21 "
22
15NETWORK_MANAGER ?= "connman-gnome" 23NETWORK_MANAGER ?= "connman-gnome"
16NETWORK_MANAGER_libc-uclibc = "" 24NETWORK_MANAGER_libc-uclibc = ""
17 25
18WEB ?= "" 26RDEPENDS_${PN}-base = "\
19#WEB = "web-webkit"
20
21RDEPENDS_packagegroup-core-x11-sato = "\
22 matchbox-desktop \ 27 matchbox-desktop \
23 matchbox-session-sato \ 28 matchbox-session-sato \
24 matchbox-keyboard \ 29 matchbox-keyboard \
30 matchbox-keyboard-applet \
31 matchbox-keyboard-im \
25 matchbox-stroke \ 32 matchbox-stroke \
26 matchbox-config-gtk \ 33 matchbox-config-gtk \
27 xcursor-transparent-theme \ 34 xcursor-transparent-theme \
28 sato-icon-theme \ 35 sato-icon-theme \
29 settings-daemon \ 36 settings-daemon \
30 gtk-sato-engine \ 37 gtk-sato-engine \
31 gthumb \
32 x11vnc \
33 libsdl \ 38 libsdl \
39 ${NETWORK_MANAGER} \
40 "
41
42# pcmanfm doesn't work on mips
43FILEMANAGER ?= "pcmanfm"
44FILEMANAGER_mips ?= ""
45
46WEB ?= ""
47#WEB = "web-webkit"
48
49RDEPENDS_${PN}-apps = "\
50 gthumb \
51 leafpad \
34 gaku \ 52 gaku \
53 x11vnc \
54 matchbox-terminal \
55 sato-screenshot \
56 ${FILEMANAGER} \
35 ${WEB} \ 57 ${WEB} \
36 ${NETWORK_MANAGER}" 58 "
59
60RDEPENDS_${PN}-games = "\
61 oh-puzzles \
62 "