summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb')
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
new file mode 100644
index 0000000000..5c01a13283
--- /dev/null
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -0,0 +1,53 @@
1DESCRIPTION = "Custom MB session files for poky"
2HOMEPAGE = "http://www.matchbox-project.org/"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "GPL"
6
7SECTION = "x11"
8RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session"
9PR = "r27"
10
11# This package is architecture specific because the session script is modified
12# based on the machine architecture.
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15SRC_URI = "file://session"
16S = "${WORKDIR}"
17
18do_install() {
19 # This is the set of machine features that the script has markers for
20 FEATURES="phone"
21 SCRIPT="${S}/sedder"
22 rm -f $SCRIPT
23 touch $SCRIPT
24 for FEAT in $FEATURES; do
25 if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then
26 echo "/feature-$FEAT/d" >> $SCRIPT
27 fi
28 done
29
30 install -d ${D}/${sysconfdir}/matchbox
31 sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
32 chmod +x ${D}/${sysconfdir}/matchbox/session
33}
34
35pkg_postinst_${PN} () {
36#!/bin/sh -e
37if [ "x$D" != "x" ]; then
38 exit 1
39fi
40
41. ${sysconfdir}/init.d/functions
42
43gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato
44gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Sato
45gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/touchscreen true
46
47if [ "`machine_id`" = "gta01" ]
48then
49 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 6"
50else
51 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 9"
52fi
53}