summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb')
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb
new file mode 100644
index 0000000000..45998633f4
--- /dev/null
+++ b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "A simple GTK+ based panel for handheld devices."
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://matchbox-panel/mb-panel.h;endline=10;md5=0b7db28f4b6863fb853d0467e590019a \
8 file://applets/startup/startup.c;endline=22;md5=b0a64fbef3097d79f8264e6907a98f03"
9
10PRIORITY = "optional"
11DEPENDS = "gtk+ startup-notification dbus dbus-glib"
12DEPENDS += " ${@base_contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
13DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
14
15PV = "0.0+svnr${SRCREV}"
16PR = "r5"
17
18RPROVIDES_${PN} = "matchbox-panel"
19RREPLACES_${PN} = "matchbox-panel"
20RCONFLICTS_${PN} = "matchbox-panel"
21
22SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
23 file://startup_fix.diff;patch=1"
24
25EXTRA_OECONF = "--enable-startup-notification --enable-dbus"
26EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"
27EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "apm", "--with-battery=apm", "",d)}"
28
29S = "${WORKDIR}/${PN}"
30
31FILES_${PN} += "${libdir}/matchbox-panel/*.so \
32 ${datadir}/matchbox-panel/brightness/*.png \
33 ${datadir}/matchbox-panel/startup/*.png "
34FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"
35
36inherit autotools pkgconfig