summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.12.bb')
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.12.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.12.bb b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.12.bb
new file mode 100644
index 0000000000..29a1a36e12
--- /dev/null
+++ b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.12.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Simple GTK+ based panel for handheld devices"
2DESCRIPTION = "A flexible always present 'window bar' for holding application \
3launchers and small 'applet' style applications"
4HOMEPAGE = "http://matchbox-project.org"
5BUGTRACKER = "http://bugzilla.yoctoproject.org/"
6
7LICENSE = "GPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
9 file://matchbox-panel/mb-panel.h;endline=10;md5=f007add2f09d6a1920ee5a28645e9ce1 \
10 file://applets/startup/startup.c;endline=22;md5=9ee7a4192e53cc00041ef445d4ff6909"
11
12DEPENDS = "gtk+3 startup-notification dbus dbus-glib dbus-glib-native"
13DEPENDS += " ${@bb.utils.contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
14DEPENDS += " ${@bb.utils.contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
15
16# The startup-notification requires x11 in DISTRO_FEATURES
17REQUIRED_DISTRO_FEATURES = "x11"
18
19SRCREV = "39fdbc40888c1c75cd7bfd9fd341e6ad58487fce"
20
21RPROVIDES:${PN} = "matchbox-panel"
22RREPLACES:${PN} = "matchbox-panel"
23RCONFLICTS:${PN} = "matchbox-panel"
24
25SRC_URI = "git://git.yoctoproject.org/${BPN};branch=master \
26 file://0001-applets-systray-Allow-icons-to-be-smaller.patch \
27 "
28
29EXTRA_OECONF = "--enable-startup-notification --enable-dbus"
30EXTRA_OECONF += " ${@bb.utils.contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"
31EXTRA_OECONF += " ${@bb.utils.contains("MACHINE_FEATURES", "apm", "--with-battery=apm", "",d)}"
32
33S = "${WORKDIR}/git"
34
35FILES:${PN} += "${libdir}/matchbox-panel/*.so \
36 ${datadir}/matchbox-panel/brightness/*.png \
37 ${datadir}/matchbox-panel/startup/*.png \
38 ${datadir}/icons/"
39FILES:${PN}-dev += "${libdir}/matchbox-panel/*.la"
40
41inherit autotools pkgconfig features_check gettext