summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_svn.bb')
-rw-r--r--meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_svn.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_svn.bb b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_svn.bb
new file mode 100644
index 0000000000..0425fec78a
--- /dev/null
+++ b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_svn.bb
@@ -0,0 +1,60 @@
1DESCRIPTION = "Matchbox virtual keyboard for X11"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://src/matchbox-keyboard.h;endline=20;md5=4ba16ff913ad245dd6d95a6c67f72526 \
8 file://applet/applet.c;endline=20;md5=e9201b3efa0a81a160b88d6feb5cf75b"
9
10DEPENDS = "libfakekey expat libxft gtk+ matchbox-panel-2"
11RDEPENDS = "formfactor dbus-wait"
12SECTION = "x11"
13PV = "0.0+svnr${SRCREV}"
14PR = "r4"
15
16SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
17 file://configure_fix.patch;patch=1;maxrev=1819 \
18 file://80matchboxkeyboard.shbg"
19
20S = "${WORKDIR}/${PN}"
21
22inherit autotools pkgconfig gettext
23
24EXTRA_OECONF = "--disable-cairo --enable-gtk-im --enable-applet"
25
26PACKAGES += "matchbox-keyboard-im matchbox-keyboard-im-dbg \
27 matchbox-keyboard-applet matchbox-keyboard-applet-dbg"
28
29FILES_${PN} = "${bindir}/* \
30 ${sysconfdir} \
31 ${datadir}/applications \
32 ${datadir}/pixmaps \
33 ${datadir}/matchbox-keyboard"
34
35FILES_matchbox-keyboard-im = "${libdir}/gtk-2.0/*/immodules/*.so"
36FILES_matchbox-keyboard-im-dbg += "${libdir}/gtk-2.0/*/immodules/.debug"
37
38FILES_matchbox-keyboard-applet = "${libdir}/matchbox-panel/*.so"
39FILES_matchbox-keyboard-applet-dbg += "${libdir}/matchbox-panel/.debug"
40
41do_install_append () {
42 install -d ${D}/${sysconfdir}/X11/Xsession.d/
43 install -m 755 ${WORKDIR}/80matchboxkeyboard.shbg ${D}/${sysconfdir}/X11/Xsession.d/
44}
45
46pkg_postinst_matchbox-keyboard-im () {
47if [ "x$D" != "x" ]; then
48 exit 1
49fi
50
51gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
52}
53
54pkg_postrm_matchbox-keyboard-im () {
55if [ "x$D" != "x" ]; then
56 exit 1
57fi
58
59gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
60}