summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.3.bb')
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.3.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.3.bb
new file mode 100644
index 0000000000..9d3a2eca33
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.3.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Matchbox Window Manager Desktop"
2DESCRIPTION = "A lightweight windows manager for embedded systems. It uses the desktop background to provide an application launcher and allows modules to be loaded for additional functionality."
3HOMEPAGE = "http://matchbox-project.org/"
4BUGTRACKER = "http://bugzilla.yoctoproject.org/"
5
6LICENSE = "GPL-2.0-or-later & LGPL-2.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/desktop.c;endline=20;md5=2e488557570c7dee53bfd0567e4273a9 \
9 file://src/main.c;endline=19;md5=5d2234b35efa927ab3ae36ebac52ba59"
10
11DEPENDS = "gtk+3 startup-notification dbus"
12SECTION = "x11/wm"
13
14SRCREV = "0fd6a0c3f3b7bbf4f4b46190d71f7aef35d6bbfd"
15SRC_URI = "git://git.yoctoproject.org/${BPN}-2;branch=master \
16 file://vfolders/ \
17 "
18
19EXTRA_OECONF = "--enable-startup-notification --with-dbus"
20
21S = "${WORKDIR}/git"
22
23inherit autotools pkgconfig features_check
24
25# The startup-notification requires x11 in DISTRO_FEATURES
26REQUIRED_DISTRO_FEATURES = "x11"
27
28do_install:append() {
29 install -d ${D}${datadir}/matchbox/vfolders/
30 install -m 0644 ${WORKDIR}/vfolders/* ${D}${datadir}/matchbox/vfolders/
31}
32
33FILES:${PN} += "${datadir}/matchbox/vfolders/"