summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_2.0.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_2.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_2.0.bb b/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
new file mode 100644
index 0000000000..21780d19ed
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9
10require rt-tests.inc
11inherit ptest
12
13SRC_URI += " \
14 file://run-ptest \
15 file://rt_bmark.py \
16 "
17# Do not install hwlatdetect
18EXTRA_OEMAKE += "PYLIB='' CROSS_COMPILE=${TARGET_PREFIX}"
19
20CFLAGS_prepend = "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}"
21
22do_install() {
23 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
24 INCLUDEDIR=${includedir}
25}
26
27do_install_ptest() {
28 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
29}
30
31RDEPENDS_${PN}-ptest += " stress python python-subprocess python-multiprocessing python-datetime python-re python-lang"
32
33FILES_${PN} += "${prefix}/src/backfire"