diff options
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_1.9.bb')
-rw-r--r-- | meta/recipes-rt/rt-tests/rt-tests_1.9.bb | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_1.9.bb b/meta/recipes-rt/rt-tests/rt-tests_1.9.bb new file mode 100644 index 0000000000..2834cabcd4 --- /dev/null +++ b/meta/recipes-rt/rt-tests/rt-tests_1.9.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | SUMMARY = "Real-Time preemption testcases" | ||
2 | HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest" | ||
3 | SECTION = "tests" | ||
4 | DEPENDS = "linux-libc-headers virtual/libc numactl" | ||
5 | LICENSE = "GPLv2 & GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
7 | |||
8 | require rt-tests.inc | ||
9 | inherit ptest | ||
10 | |||
11 | SRC_URI += " \ | ||
12 | file://run-ptest \ | ||
13 | file://rt_bmark.py \ | ||
14 | file://0001-Makefile-Allow-for-CC-and-AR-to-be-overridden.patch \ | ||
15 | " | ||
16 | |||
17 | # rt-tests needs PI mutex support in libc | ||
18 | COMPATIBLE_HOST_libc-musl = 'null' | ||
19 | |||
20 | # Do not install hwlatdetect | ||
21 | EXTRA_OEMAKE += "PYLIB=''" | ||
22 | |||
23 | do_install() { | ||
24 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \ | ||
25 | INCLUDEDIR=${includedir} | ||
26 | } | ||
27 | |||
28 | do_install_ptest() { | ||
29 | cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH} | ||
30 | } | ||
31 | |||
32 | RDEPENDS_${PN}-ptest += " stress-ng python3 python3-multiprocessing python3-datetime python3-misc" | ||
33 | |||
34 | FILES_${PN} += "${prefix}/src/backfire" | ||
35 | RDEPENDS_${PN} += "bash" | ||