summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_0.94.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_0.94.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_0.94.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.94.bb b/meta/recipes-rt/rt-tests/rt-tests_0.94.bb
new file mode 100644
index 0000000000..7d703925a8
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_0.94.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9
10require rt-tests.inc
11inherit ptest
12
13SRC_URI += "file://run-ptest \
14 file://rt_bmark.py \
15 "
16# Do not install hwlatdetect
17EXTRA_OEMAKE += "PYLIB='' CROSS_COMPILE=${TARGET_PREFIX}"
18
19CFLAGS_prepend = "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}"
20
21do_install() {
22 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
23 INCLUDEDIR=${includedir}
24}
25
26do_install_ptest() {
27 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
28}
29
30RDEPENDS_${PN}-ptest += " stress python python-subprocess python-multiprocessing python-datetime python-re python-lang"
31
32FILES_${PN} += "${prefix}/src/backfire"