diff options
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_0.92.bb')
-rw-r--r-- | meta/recipes-rt/rt-tests/rt-tests_0.92.bb | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.92.bb b/meta/recipes-rt/rt-tests/rt-tests_0.92.bb new file mode 100644 index 0000000000..fbe2f669e8 --- /dev/null +++ b/meta/recipes-rt/rt-tests/rt-tests_0.92.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | SUMMARY = "Real-Time preemption testcases" | ||
2 | HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest" | ||
3 | SECTION = "tests" | ||
4 | DEPENDS = "linux-libc-headers virtual/libc" | ||
5 | LICENSE = "GPLv2 & GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ | ||
7 | file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \ | ||
8 | file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949" | ||
9 | |||
10 | require rt-tests.inc | ||
11 | inherit ptest | ||
12 | |||
13 | SRC_URI += "file://run-ptest \ | ||
14 | file://rt_bmark.py \ | ||
15 | " | ||
16 | # Do not install hwlatdetect | ||
17 | EXTRA_OEMAKE += "PYLIB=''" | ||
18 | |||
19 | do_install() { | ||
20 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \ | ||
21 | INCLUDEDIR=${includedir} | ||
22 | } | ||
23 | |||
24 | do_install_ptest() { | ||
25 | cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH} | ||
26 | } | ||
27 | |||
28 | RDEPENDS_${PN}-ptest += " stress python python-subprocess python-multiprocessing python-datetime python-re python-lang" | ||
29 | |||
30 | FILES_${PN} += "${prefix}/src/backfire" | ||