diff options
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb')
-rw-r--r-- | meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb | 26 |
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb new file mode 100644 index 0000000000..012b2dd0a7 --- /dev/null +++ b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | SUMMARY = "Hardware latency detector" | ||
2 | DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)." | ||
3 | HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest" | ||
4 | SECTION = "tests" | ||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
7 | |||
8 | require rt-tests.inc | ||
9 | inherit python3-dir | ||
10 | |||
11 | EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages" | ||
12 | |||
13 | do_compile() { | ||
14 | oe_runmake hwlatdetect | ||
15 | } | ||
16 | |||
17 | do_install() { | ||
18 | oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \ | ||
19 | MANDIR=${mandir} INCLUDEDIR=${includedir} | ||
20 | |||
21 | sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py | ||
22 | } | ||
23 | |||
24 | FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py" | ||
25 | RDEPENDS_${PN} = "python3 python3-subprocess python3-textutils" | ||
26 | RRECOMMENDS_${PN} = "kernel-module-hwlat-detector" | ||