summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
new file mode 100644
index 0000000000..a850a2d42a
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
@@ -0,0 +1,24 @@
1pickDESCRIPTION = "Python hardware latency detector"
2HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
3SECTION = "tests"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6RDEPENDS = "python python-subprocess python-textutils"
7RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"
8
9require rt-tests.inc
10
11PR = "${INC_PR}.0"
12
13EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
14
15do_compile() {
16 oe_runmake hwlatdetect
17}
18
19do_install() {
20 oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
21 MANDIR=${mandir} INCLUDEDIR=${includedir}
22}
23
24FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"