summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
new file mode 100644
index 0000000000..a5d2eac5cf
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Hardware latency detector"
2DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
3HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
4SECTION = "tests"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7RDEPENDS_${PN} = "python python-subprocess python-textutils"
8RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"
9
10require rt-tests.inc
11
12EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
13
14do_compile() {
15 oe_runmake hwlatdetect
16}
17
18do_install() {
19 oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
20 MANDIR=${mandir} INCLUDEDIR=${includedir}
21}
22
23FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"