summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt/qt-apps/qmmp_0.4.1.bb')
-rw-r--r--meta/recipes-qt/qt-apps/qmmp_0.4.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb b/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb
new file mode 100644
index 0000000000..5f971e8b47
--- /dev/null
+++ b/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Qmmp (Qt-based Multimedia Player) is an audio-player, written with help of Qt library"
2HOMEPAGE = "http://qmmp.ylsoftware.com"
3LICENSE = "GPLv2"
4SECTION = "multimedia"
5
6DEPENDS = "qt4-x11-free"
7RDEPENDS = "qt4-x11-free libmad libvorbis libogg taglib alsa-lib curl"
8
9SRC_URI = "http://qmmp.ylsoftware.com/files/qmmp-0.4.1.tar.bz2"
10
11PARALLEL_MAKE = ""
12
13inherit qmake2 pkgconfig
14
15do_configure_prepend() {
16 # fix qt4 lrelease name
17 sed -i -e 's/lrelease-qt4/lrelease4/' ${S}/qmmp.pro
18
19 # disable the unsupported plugin
20 for plugin in sndfile wavpack ; do
21 sed -i -e "s/$plugin//" ${S}/src/plugins/Input/Input.pro
22 done
23 sed -i -e 's/mms//' ${S}/src/plugins/Transports/Transports.pro
24 sed -i -e 's/srconverter//' ${S}/src/plugins/Effect/Effect.pro
25
26 sed -i -e 's/^CONFIG/#CONFIG/' ${S}/qmmp.pri
27 sed -i -e 's/CONFIG += WITH_ENCA/#CONFIG += WITH_ENCA/' ${S}/qmmp.pri
28}
29
30do_install() {
31 oe_runmake INSTALL_ROOT=${D} install
32}